1006. Sign In and Sign Out (25)

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
Sample Output:
SC3021234 CS301133
主要思路:1、将标准时间格式转化为秒数表示,即可以直接比较时间大小
	2、每次取得输入数据即可以同步判断有无更早进入或者更晚离开的同学,若有,则及时记录下来
#include <iostream>
#include<string>
using namespace std;
#define N 100

int adapter(char str[])//利用标准格式将时间转化为秒的计数
{
    return ((str[0]-'0')*10+(str[1]-'0'))*3600+((str[3]-'0')*10+(str[4]-'0'))*60+((str[6]-'0')*10+(str[7]-'0'));
}

int main(int argc, const char * argv[])
{
    int M=0;
    char number[N]={0};
    char signin_time[10]={0};
    char signout_time[10]={0};
    char unlock_number[N]={0};
    char lock_number[N]={0};
    int unlock=3600*24;
    int lock=0;
    cin>>M;
    for (int i=0; i<M; ++i)
    {
        cin>>number;
        cin>>signin_time;
        cin>>signout_time;
        if (adapter(signin_time)<unlock)//更早的开锁人出现
        {
            strcpy(unlock_number, number);
            unlock=adapter(signin_time);
        }
        if (adapter(signout_time)>lock)//更晚的落锁人出现
        {
            strcpy(lock_number, number);
            lock=adapter(signout_time);
        }
    }
    cout<<unlock_number<<' '<<lock_number;
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值