PPP、HDLC及MGRE基础练习

练习要求

1.R5为ISP,只能进行IP地址配置;其所有地址均为公有IP地址
2.R1和R5间使用PPP的PAP认证,R5为主认证方;
R2与R5之间使用PPP的chap认证,R5为主认证方;
R3与R5之间使用HDLC封装。
3.R1/R2/R3构建一个MGRE环境,R1为中心站点;R1、R4间为点到点的GRE。
4.整个私有网络基于RIP全网可达
5.所有PC设置私有IP为源IP,可以访问R5环回

拓扑图

拓扑图

配置过程

配置IP

R1

[r1]int g 0/0/0
[r1-GigabitEthernet0/0/0]ip address 192.168.1.1 24
[r1-GigabitEthernet0/0/0]int s 4/0/0
[r1-Serial4/0/0]ip ad 15.0.0.1 8

R2

[r2]int g 0/0/0
[r2-GigabitEthernet0/0/0]ip ad 192.168.2.1 24
[r2-GigabitEthernet0/0/0]int s 4/0/0
[r2-Serial4/0/0]ip ad 25.0.0.1 8

R3

[r3]int g 0/0/0
[r3-GigabitEthernet0/0/0]ip ad 192.168.3.1 24
[r3-GigabitEthernet0/0/0]int s 4/0/0
[r3-Serial4/0/0]ip ad 35.0.0.1 8

R4

[r4-GigabitEthernet0/0/0]ip ad 192.168.4.1 24
[r4]interface g 0/0/1
[r4-GigabitEthernet0/0/1]ip ad 45.0.0.1 8

ISP

[isp]int s 3/0/0
[isp-Serial3/0/0]ip ad 15.0.0.2 8
[isp-Serial3/0/0]int s 3/0/1
[isp-Serial3/0/1]ip ad 25.0.0.2 8
[isp-Serial3/0/1]int s 4/0/0
[isp-Serial4/0/0]ip ad 35.0.0.2 8
[isp-Serial4/0/0]int g 0/0/0
[isp-GigabitEthernet0/0/0]ip ad 45.0.0.2 8

配置PPP

R1 — R5 PAP认证

[isp]aaa
[isp-aaa]local-user r1 password cipher pap123456
Info: Add a new user.
[isp-aaa]local-user r1 service-type ppp 
[isp-aaa]int s 3/0/0
[isp-Serial3/0/0]ppp authentication-mode pap

[r1]int s 4/0/0
[r1-Serial4/0/0]ppp pap local-user r1 password cipher pap123456

R2 — R5 CHAP认证

[isp]aaa
[isp-aaa]local-user r2 password cipher chap123456
Info: Add a new user.
[isp-aaa]local-user r2 service-type ppp
[isp-aaa]int s 3/0/1
[isp-Serial3/0/1]ppp authentication-mode chap

[r2]int s 4/0/0
[r2-Serial4/0/0]ppp chap user r2 
[r2-Serial4/0/0]ppp chap password cipher chap123456

配置R3 — R5 HDLC

[isp-Serial3/0/1]int s 4/0/0
[isp-Serial4/0/0]link-protocol hdlc

[r3]int s 4/0/0
[r3-Serial4/0/0]link-protocol hdlc

配置 R1 — R2 — R3 MGRE

R1

[r1]int t 0/0/0
[r1-Tunnel0/0/0]ip ad 192.168.5.1 24	
[r1-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r1-Tunnel0/0/0]source 15.0.0.1
Oct 30 2023 19:43:20-08:00 r1 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 	
[r1-Tunnel0/0/0]nhrp network-id 100

R2

[r2]int t 0/0/0
[r2-Tunnel0/0/0]ip ad 192.168.5.2 24
[r2-Tunnel0/0/0]tunnel-protocol gre p2mp 	
[r2-Tunnel0/0/0]source Serial 4/0/0
Oct 30 2023 19:45:26-08:00 r2 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[r2-Tunnel0/0/0]nhrp network-id 100
[r2-Tunnel0/0/0]nhrp entry 192.168.5.1 15.0.0.1 register

R3

[r3]int t 0/0/0
[r3-Tunnel0/0/0]ip ad 192.168.5.3 24	
[r3-Tunnel0/0/0]tunnel-protocol gre p2mp 
[r3-Tunnel0/0/0]source Serial 4/0/0
Oct 30 2023 19:48:03-08:00 r3 %%01IFNET/4/LINK_STATE(l)[0]:The line protocol IP 
on the interface Tunnel0/0/0 has entered the UP state. 
[r3-Tunnel0/0/0]nhrp network-id 100
[r3-Tunnel0/0/0]nhrp entry 192.168.5.1 15.0.0.1 register

配置 R1 — R4 GRE

R1

[r1]int t 0/0/1
[r1-Tunnel0/0/1]ip ad 192.168.6.1 24
[r1-Tunnel0/0/1]tunnel-protocol gre 
[r1-Tunnel0/0/1]source Serial 4/0/0
[r1-Tunnel0/0/1]destination 45.0.0.1

R2

[r4]int t 0/0/1
[r4-Tunnel0/0/1]ip address 192.168.6.2 24
[r4-Tunnel0/0/1]tunnel-protocol gre 
[r4-Tunnel0/0/1]source GigabitEthernet 0/0/1	
[r4-Tunnel0/0/1]description 15.0.0.1

配置路由

[r1]ip route-static 0.0.0.0 0 15.0.0.2

[r2]ip route-static 0.0.0.0 0 25.0.0.2

[r3]ip route-static 0.0.0.0 0 35.0.0.2

[r4]ip route-static 0.0.0.0 0 45.0.0.2

配置RIP

R1

RIP
[r1]rip 1
[r1-rip-1]v 2
[r1-rip-1]network 192.168.1.0 
[r1-rip-1]network 192.168.5.0
[r1-rip-1]network 192.168.6.0
[r1-rip-1]network 15.0.0.0
开启伪广播及关闭水平分割
[r1]int t 0/0/0	
[r1-Tunnel0/0/0]nhrp entry multicast dynamic 
[r1-Tunnel0/0/0]undo rip split-horizon

R2

[r2]rip 1
[r2-rip-1]v 2
[r2-rip-1]network 192.168.2.0
[r2-rip-1]n 192.168.5.0
[r2-rip-1]n 25.0.0.0

R3

[r3]rip 1
[r3-rip-1]v 2
[r3-rip-1]network 192.168.3.0
[r3-rip-1]n 192.168.5.0
[r3-rip-1]n 35.0.0.0

R4

[r4]rip 1
[r4-rip-1]v 2
[r4-rip-1]n 192.168.4.0
[r4-rip-1]n 192.168.6.0
[r4-rip-1]n 45.0.0.0

配置R5环回

[isp-Serial4/0/0]int l 1
[isp-LoopBack1]ip ad 5.5.5.5 24

配置NATP

R1

[r1]acl 2000
[r1-acl-basic-2000]rule permit source 192.168.1.0 0.0.0.255
[r1-GigabitEthernet0/0/0]int s 4/0/0
[r1-Serial4/0/0]nat outbound 2000

R2

[r2]acl 2000
[r2-acl-basic-2000]rule permit source 192.168.2.0 0.0.0.255
[r2-acl-basic-2000]int s 4/0/0
[r2-Serial4/0/0]nat o 2000

R3

[r3]acl 2000
[r3-acl-basic-2000]rule permit source 192.168.3.0 0.0.0.255
[r3-acl-basic-2000]int s 4/0/0
[r3-Serial4/0/0]nat o 2000

R4

[r4]acl 2000
[r4-acl-basic-2000]ru p s 192.168.4.0 0.0.0.255
[r4-GigabitEthernet0/0/0]int g 0/0/1
[r4-GigabitEthernet0/0/1]nat o 2000
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 1
    评论
评论 1
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值