带权并查集

In 12th Zhejiang College Students Games 2007, there was a new stadium built in Zhejiang Normal University. It was a modern stadium which could hold thousands of people. The audience Seats made a circle. The total number of columns were 300 numbered 1–300, counted clockwise, we assume the number of rows were infinite.
These days, Busoniya want to hold a large-scale theatrical performance in this stadium. There will be N people go there numbered 1–N. Busoniya has Reserved several seats. To make it funny, he makes M requests for these seats: A B X, which means people numbered B must seat clockwise X distance from people numbered A. For example: A is in column 4th and X is 2, then B must in column 6th (6=4+2).
Now your task is to judge weather the request is correct or not. The rule of your judgement is easy: when a new request has conflicts against the foregoing ones then we define it as incorrect, otherwise it is correct. Please find out all the incorrect requests and count them as R.
InputThere are many test cases:
For every case:
The first line has two integer N(1<=N<=50,000), M(0<=M<=100,000),separated by a space.
Then M lines follow, each line has 3 integer A(1<=A<=N), B(1<=B<=N), X(0<=X<300) (A!=B), separated by a space.
OutputFor every case:
Output R, represents the number of incorrect request.
Sample Input
10 10
1 2 150
3 4 200
1 5 270
2 6 200
6 5 80
4 7 150
8 9 100
4 8 50
1 7 100
9 2 100
Sample Output
2
在2007年第十二届浙江省大学生运动会上,浙江师范大学新建了一座体育场。这是一个可以容纳数千人的现代化体育场。观众席围成一圈。列的总数是300,编号为1–300,顺时针计数,我们假设行的数量是无限的。 最近,布索尼娅想在这个体育场举行一场大型的戏剧表演。将有N个人去那里,人数是1——N。布索尼娅已经预订了好几个座位。为了搞笑,他对这些座位提出了M个要求:A B X,这意味着编号B的人必须顺时针坐X距离编号A的人。例如:A在第4列,X是2,那么B必须在第6列(6=4+2)。 现在你的任务是判断请求是否正确。你的判断规则很简单:当一个新请求与前面的冲突时,我们将其定义为不正确,否则它是正确的。请找出所有不正确的请求并将其计算为R。

#include<stdio.h>
#include<string.h>
int f[55000],d[55000];
int getf(int v)
{
    if(f[v]==v)
        return v;
    else
    {
        int s=f[v];
        f[v]=getf(f[v]);
        d[v]=d[v]+d[s];
        return f[v];
    }
}
void merge(int v,int u)
{
    int t1,t2;
    t1=getf(v);
    t2=getf(u);
    if(t1!=t2)
        f[t2]=t1;
    return ;
}
int main()
{
    int m,n,x,y,z,i,j;
    while(~scanf("%d%d",&n,&m))
    {
        int sum=0;
        for(i=1;i<=n;i++)
            f[i]=i;
            memset(d,0,sizeof(d));
            for(i=0;i<m;i++)
            {
                scanf("%d%d%d",&x,&y,&z);
                int fx=getf(x);
                int fy=getf(y);
                if(fx==fy)
                {
                    int w=d[y]-d[x];
                    if(w!=z)
                        sum++;
                }
                else
                {
                    merge(x,y);
                    d[fy]=d[x]+z-d[y];
                }
            }
            printf("%d\n",sum);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值