hdu5441(离线带权并查集)

10 篇文章 0 订阅
4 篇文章 0 订阅

Travel

Time Limit: 1500/1000 MS (Java/Others)    Memory Limit: 131072/131072 K (Java/Others)
Total Submission(s): 4372    Accepted Submission(s): 1456


Problem Description
Jack likes to travel around the world, but he doesn’t like to wait. Now, he is traveling in the Undirected Kingdom. There are  n cities and  m bidirectional roads connecting the cities. Jack hates waiting too long on the bus, but he can rest at every city. Jack can only stand staying on the bus for a limited time and will go berserk after that. Assuming you know the time it takes to go from one city to another and that the time Jack can stand staying on a bus is  x minutes, how many pairs of city  (a,b) are there that Jack can travel from city  a to  b without going berserk?
 

Input
The first line contains one integer  T,T5, which represents the number of test case.

For each test case, the first line consists of three integers  n,m and  q where  n20000,m100000,q5000. The Undirected Kingdom has  n cities and  mbidirectional roads, and there are  q queries.

Each of the following  m lines consists of three integers  a,b and  d where  a,b{1,...,n} and  d100000. It takes Jack  d minutes to travel from city  a to city  b and vice versa.

Then  q lines follow. Each of them is a query consisting of an integer  x where  x is the time limit before Jack goes berserk.

 

Output
You should print  q lines for each test case. Each of them contains one integer as the number of pair of cities  (a,b) which Jack may travel from  a to  b within the time limit  x.

Note that  (a,b) and  (b,a) are counted as different pairs and  a and  b must be different cities.
 

Sample Input
 
 
1 5 5 3 2 3 6334 1 5 15724 3 5 5705 4 3 12382 1 3 21726 6000 10000 13000
 

Sample Output
 
 
2 6

12

题意:给你个无向图,n个点,m条边,每条边带权值,有q次询问,问每次给出一个值,求无向图的边权不大于这个值的点对数。

解析:起先一直理解成只有两点直接连接才可以算符合题意的点对,但是第二个样例一直解释不通。原来是可以间接通过其他点的。

样例解释:1:3-5 5705<6000,ans=2*1;

2:3-5 5705<10000, 2-3 6334<10000, 这里还可以从2-3-5,也就是2-5 也算一个点对。因为题意说他可以在一个城市休息,然后再出发。

分析:按照边权从小到大排序,然后再对每次的值进行比较,若大于则停止。具体详见代码

代码:

#include<iostream>
#include<cstdio>
#include<algorithm>
#include<cstring>
using namespace std;
typedef long long ll;
int t;
int n,m,q;
struct  path
{
    int s;
    int e;
    int dis;
     bool operator <(const path &x)const{
      return dis<x.dis;
     }
}P[100005];
struct limi
{
    int id;
    int limit;
    bool operator <(const limi &x)const{
      return limit<x.limit;
     }
}L[100005];
ll re[5005];
int parent[20005];
int mp[20005];
int Find(int mubiao)
{
    if(parent[mubiao]!=mubiao)
        parent[mubiao]=Find(parent[mubiao]);
    return parent[mubiao];
}
void init()
{
    for(int j=1;j<=n;j++)
    {
        parent[j]=j;
        mp[j]=1;
    }
    memset(re,0,sizeof(re));
}
int main()
{
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d",&n,&m,&q);
        for(int i=0;i<m;i++)
            scanf("%d%d%d",&P[i].s,&P[i].e,&P[i].dis);
        sort(P,P+m);
        for(int i=0;i<q;i++)
        {
            L[i].id=i;
            scanf("%d",&L[i].limit);
        }
        sort(L,L+q);
        init();
        int gg=0;
        ll he=0;
        for(int i=0;i<q;i++)
        {
            while(gg<m&&L[i].limit>=P[gg].dis)
            {
                int ss=Find(P[gg].s);
                int ee=Find(P[gg].e);
                if(ss!=ee)
                {
                    he+=mp[ss]*mp[ee];
                    parent[ee]=ss;
                    mp[ss]+=mp[ee];
                }
                gg++;
            }
            re[L[i].id]=he;
        }
        for(int i=0;i<q;i++)
            printf("%lld\n",2*re[i]);
}
return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值