zoj3665 Yukari's Birthday

16 篇文章 0 订阅
Yukari's Birthday

Time Limit: 2 Seconds Memory Limit: 32768 KB

Today is Yukari's n-th birthday. Ran and Chen hold a celebration party for her. Now comes the most important part, birthday cake! But it's a big challenge for them to place n candles on the top of the cake. As Yukari has lived for such a long long time. Though she herself insists that she is a 17-year-old girl.

To make the birthday cake look more beautiful, Ran and Chen decide to place them like r ≥ 1 concentric circles. They place ki candles equidistantly on the i-th circle, where k ≥ 2, 1 ≤ ir. And it's optional to place at most one candle at the center of the cake. In case that there are a lot of different pairs of r and k satisfying these restrictions, they want to minimize r × k. If there is still a tie, minimize r.

Input

There are about 10,000 test cases. Process to the end of file.

Each test consists of only an integer 18 ≤ n ≤ 1012.

Output

For each test case, output r and k.

Sample Input
18
111
1111
Sample Output
1 17
2 10
3 10
大坑题 ,枚举r 二分k,这样就可以了, 但是要注意 ,会出现__int64爆掉的情况,这样的话,那就要加很多的判断了!
#include <iostream>
#include <stdio.h>
#include <string.h>
using namespace std;
__int64 n;
int fccos(__int64 x,int ii)
{
    __int64 sum=0,kk=1;
    int i;

    for(i=1;i<=ii;i++)
    {
        if(kk>n/x)
        return 0;
        kk*=x;
        if(kk>n||kk<0)
        return 0;
        sum+=kk;
       // printf("  %I64d  ",sum);
       if(sum>n||sum<0)
            return 0;
    }
    //printf("%I64d %I64d ii%d\n",sum,x,ii);
    if(sum==n||sum==n-1)
    return 2;
    if(sum>n)
    return 0;
    if(sum<n-1)
    return 1;
}
__int64 twocut(int x)
{
    __int64 s,e,mid;
    s=1;e=n;
    while(s<=e)
    {
        mid=(s+e)>>1;
        int temp=fccos(mid,x);
        if(temp==2)
        {
           return mid;
        }
        else if(temp==1)
            s=mid+1;
        else if(temp==0)
            e=mid-1;
       // printf("%d ",mid);
    }
    return -1;
}
int main()
{
    int i,num;
   __int64 maxx,ansr,ansk;
   while(scanf("%I64d",&n)!=EOF)
   {
       maxx=-1,ansr=-1,ansk=-1;
       //num=log((double)n)/log(2.0)+1;
       //printf("num%d\n",num);
       for(i=1;i<=60;i++)
       {
           __int64 k=twocut(i);
           if(k<0)
           continue;
           __int64 temp=i*k;
           if(maxx==-1)
           {
               maxx=temp;
               ansr=i;
               ansk=k;
           }
           else if(temp<maxx)
           {
               maxx=temp;
               ansr=i;
               ansk=k;
           }
           else if(temp==maxx&&i<ansr)
           {
               maxx=temp;
               ansr=i;
               ansk=k;
           }
       }

       printf("%I64d %I64d\n",ansr,ansk);
   }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值