2013年4月_武科大程序设计大赛_解题报告(problem 1004)

Let the Balloon Rise

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 0    Accepted Submission(s): 0


Problem Description
  
  
Contest time again! How excited it is to see balloons floating around. But to tell you a secret, the judges' favorite time is guessing the most popular problem. When the contest is over, they will count the balloons of each color and find the result. This year, they decide to leave this lovely job to you.
 

Input
  
  
Input contains multiple test cases. Each test case starts with a number N (0 < N <= 1000) -- the total number of balloons distributed. The next N lines contain one color each. The color of a balloon is a string of up to 15 lower-case letters. A test case with N = 0 terminates the input and this test case is not to be processed.
 

Output
  
  
For each case, print the color of balloon for the most popular problem on a single line. It is guaranteed that there is a unique solution for each test case.
 

Sample Input
  
  
5 green red blue red red 3 pink orange pink 0
 

Sample Output
  
  
red pink
题目说了一大串,意思就是找到出现次数最多的字符串。
可以将颜色字符串保存到数组a中,再用一个数组x记录每个字符串出现的次数,每读入一个
颜色,就在a中查找并比较。
#include<stdio.h>
#include<string.h>
int main()
{
	int n,i,top,j,k,max,ok;
	char a[100][100];
	char b[100];
	int x[100];
    while(scanf("%d",&n)&&n!=0)
	{  
	  memset(x,0,sizeof(x));
      top=0;ok=1;
      for(i=1;i<=n;i++)
        {
		  ok=1;
        scanf("%s",&b);

           for(j=1;j<=top;j++)			//如果在a[j]中找到当前字符串,则x[j]++,计数
               if(strcmp(a[j],b)==0)
                  {x[j]++;ok=0;break;}

                  if(ok) strcpy(a[++top],b);	//如果没有找到,则把当前的字符串存入a中;
                 
        }
        max=0;
 for(i=1;i<=top;i++)
     if(x[i]>max){max=x[i];k=i;}		//找到计数最大的下标x[j],输出对应的字符串a[j]
     printf("%s\n",a[k]);
	}
return 0;}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

TommyTT

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值