POJ 1759 详解二分可以解决的原因

Description

The New Year garland consists of N lamps attached to a common wire that hangs down on the ends to which outermost lamps are affixed. The wire sags under the weight of lamp in a particular way: each lamp is hanging at the height that is 1 millimeter lower than the average height of the two adjacent lamps.

The leftmost lamp in hanging at the height of A millimeters above the ground. You have to determine the lowest height B of the rightmost lamp so that no lamp in the garland lies on the ground though some of them may touch the ground.

You shall neglect the lamp’s size in this problem. By numbering the lamps with integers from 1 to N and denoting the ith lamp height in millimeters as Hi we derive the following equations:
在这里插入图片描述

H1 = A
Hi = (Hi-1 + Hi+1)/2 - 1, for all 1 < i < N
HN = B
Hi >= 0, for all 1 <= i <= N

The sample garland with 8 lamps that is shown on the picture has A = 15 and B = 9.75.

Input

The input file consists of a single line with two numbers N and A separated by a space. N (3 <= N <= 1000) is an integer representing the number of lamps in the garland, A (10 <= A <= 1000) is a real number representing the height of the leftmost lamp above the ground in millimeters.

Output

Write to the output file the single real number B accurate to two digits to the right of the decimal point representing the lowest possible height of the rightmost lamp.

Sample Input

692 532.81

Sample Output

446113.34

题目解析

这道题第一反应是二分枚举答案,但是知道了H1,Hn,如何确定中间是否存在小于0的点呢?这个比较困难,所以,我们就从递推式出发,Hi=(Hi-1+Hi+1)/2+1,从而推出Hi+1=-Hi-1+2*Hi+2,意思就是说知道前两项,就能推出第三项,由此,我们萌发出二分枚举第二项的思路。
为何能通过二分来得出最小的Hn呢?
我们可以通过数学归纳法,求得Hi的通项递推式,就是-(i-2)*x1+(i-1)x2+(i-1)(i-2),对x2求偏导,可以发现,原表达式是关于x2的一个单调递增序列,言外之意,x2越小,xn就越小,所以就可以放心大胆的去二分枚举x2啦。

代码

#include<stdio.h>
#include<string.h>
#include<iostream>
#include<queue>
#include<vector>
#include<algorithm>
#include<utility>
#include<cmath>
#include<limits.h>
#include<math.h>
#include<map>
#define inf 0x3f3f3f3f
using namespace std;
typedef pair<int,int> P;
typedef long long ll;
double res;
int n;
double A;
double *arr;
bool Ok(double mid){
	arr[2]=mid;
	for(int i=3;i<=n;i++){
		double temp=-arr[i-2]+2*arr[i-1]+2;
		if(temp<0){
			return false;
		}
		arr[i]=temp;
	}
	return true;
}
int main() {
	while(scanf("%d%lf",&n,&A)!=EOF){
		double L=0.0;
		double R=1e10;
		arr=new double[n+1];
		arr[1]=A;
		for(int i=0;i<100;i++){
			double mid=L+(R-L)/2;
			if(Ok(mid)){
				R=mid; 
			}else{
				L=mid;
			}
		}
		printf("%.2f\n",arr[n]);
	}
	return 0;
}

  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值