poj 2456 二分

Aggressive cows
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 16384 Accepted: 7837

Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000). 

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?

Input

* Line 1: Two space-separated integers: N and C 

* Lines 2..N+1: Line i+1 contains an integer stall location, xi

Output

* Line 1: One integer: the largest minimum distance

Sample Input

5 3
1
2
8
4
9

Sample Output

3

题意:n个牛栏放c头牛,求牛之间最短距离的最大值。

分析:二分距离,c(x):能在此距离下安排完全部牛。

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INF 0x3f3f3f3f
#define MAX 100
typedef long long ll;
int n,c;
int x[100001];

bool C(int dis)
{
	int lx = 0,nx = lx+1;
	for(int i = 1;i < c; i++){
		while(nx < n && x[nx] < x[lx]+dis) nx++;
		if(nx == n) return false;
		lx = nx;
		nx = lx+1;
	}
	return true;
}

int main(int argc, char const* argv[])
{
#ifndef ONLINE_JUDGE
    freopen("in.txt", "r", stdin);
    freopen("out.txt", "w", stdout);
#endif
	cin >> n >> c;
	for (int i = 0; i < n; i += 1) cin >> x[i];
	sort(x,x+n);
	int lb = 0,ub = INF;
	while(ub-lb>1){
		int mid = (ub+lb)/2;
		if(C(mid)) lb = mid;
		else ub = mid;
	}
	printf("%d\n",lb);
	return 0;
}

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值