poj2318 TOYS


Description

Calculate the number of toys that land in each bin of a partitioned toy box. 
Mom and dad have a problem - their child John never puts his toys away when he is finished playing with them. They gave John a rectangular box to put his toys in, but John is rebellious and obeys his parents by simply throwing his toys into the box. All the toys get mixed up, and it is impossible for John to find his favorite toys. 

John's parents came up with the following idea. They put cardboard partitions into the box. Even if John keeps throwing his toys into the box, at least toys that get thrown into different bins stay separated. The following diagram shows a top view of an example toy box. 
 
For this problem, you are asked to determine how many toys fall into each partition as John throws them into the toy box.

Input

The input file contains one or more problems. The first line of a problem consists of six integers, n m x1 y1 x2 y2. The number of cardboard partitions is n (0 < n <= 5000) and the number of toys is m (0 < m <= 5000). The coordinates of the upper-left corner and the lower-right corner of the box are (x1,y1) and (x2,y2), respectively. The following n lines contain two integers per line, Ui Li, indicating that the ends of the i-th cardboard partition is at the coordinates (Ui,y1) and (Li,y2). You may assume that the cardboard partitions do not intersect each other and that they are specified in sorted order from left to right. The next m lines contain two integers per line, Xj Yj specifying where the j-th toy has landed in the box. The order of the toy locations is random. You may assume that no toy will land exactly on a cardboard partition or outside the boundary of the box. The input is terminated by a line consisting of a single 0.

Output

The output for each problem will be one line for each separate bin in the toy box. For each bin, print its bin number, followed by a colon and one space, followed by the number of toys thrown into that bin. Bins are numbered from 0 (the leftmost bin) to n (the rightmost bin). Separate the output of different problems by a single blank line.

Sample Input

5 6 0 10 60 0
3 1
4 3
6 8
10 10
15 30
1 5
2 1
2 8
5 5
40 10
7 9
4 10 0 10 100 0
20 20
40 40
60 60
80 80
 5 10
15 10
25 10
35 10
45 10
55 10
65 10
75 10
85 10
95 10
0

Sample Output

0: 2
1: 1
2: 1
3: 1
4: 0
5: 1

0: 2
1: 2
2: 2
3: 2
4: 2

Hint

As the example illustrates, toys that fall on the boundary of the box are "in" the box.



题意:一个矩形箱子,左上角与右下角的坐标给出,里面有n块板把箱子里的空间分隔成许多个分区,给出这些板在上边的x坐标、下边的x坐标,以及一堆玩具的坐标,求这些分区里的玩具数目。

本题思路:叉积+二分搜索。由于点必定在格子中,因此,用目标点和格子边上的四个点进行叉积运算(运用右手定则),点在格子的“左边”的右边且在格子的“右边”的左边时,即在该格子中,否则,根据叉积结果二分搜索。

      

#include <algorithm>
#include <iostream>
#include <cstring>
#include <cstdlib>
#include <vector>
#include <queue>
#include <cstdio>
#include <cmath>
#include <string>
#include <stack>
#include <cctype>
using namespace std;

struct Lpoint
{
    int x,y;
}; //点

struct point
{
    Lpoint a,b;
};
point aa[5005];
int bb[5005];

int xmulti(Lpoint p1,Lpoint p2,Lpoint p0)
{
    return((p1.x-p0.x) * (p2.y-p0.y) -
           (p2.x-p0.x) * (p1.y-p0.y));
}//(p1-p0)*(p2-p0)的叉乘

void BSearch(Lpoint a,int n)
{
    int l=0;
    int r=n-1;
    int mi;
    while(l<r)
    {
        //二分搜索找点
        mi=(l+r)>>1;
        if(xmulti(a, aa[mi].a, aa[mi].b)>0)
            l=mi+1;
        else
            r=mi;
    }
    //判断是否在格子中
     if(xmulti(a, aa[l].a, aa[l].b)<0)
        bb[l]++;
     else
        bb[l+1]++;
}
int main()
{
    int n,m;
    int t1,t2;
    Lpoint p1,p2;
    Lpoint c;

    while(~scanf("%d",&n),n)
    {
        int i,j,k;
        scanf("%d%d%d%d%d",&m,&p1.x,&p1.y,&p2.x,&p2.y);
        for(i=0; i<n; i++)
        {
            scanf("%d%d",&t1,&t2);
            aa[i].a.x=t1;
            aa[i].a.y=p1.y;
            aa[i].b.x=t2;
            aa[i].b.y=p2.y;
        }
         memset(bb, 0, sizeof (bb));
        for (i = 0; i < m; i++)
        {
            scanf ("%d%d", &c.x, &c.y);
            BSearch(c, n);
        }

       for (i = 0; i <= n; i++)
            printf ("%d: %d\n", i, bb[i]);
        printf("\n");
    }

    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值