poj2536 Gopher II


Gopher II
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 6168 Accepted: 2547

Description

The gopher family, having averted the canine threat, must face a new predator. 

The are n gophers and m gopher holes, each at distinct (x, y) coordinates. A hawk arrives and if a gopher does not reach a hole in s seconds it is vulnerable to being eaten. A hole can save at most one gopher. All the gophers run at the same velocity v. The gopher family needs an escape strategy that minimizes the number of vulnerable gophers.

Input

The input contains several cases. The first line of each case contains four positive integers less than 100: n, m, s, and v. The next n lines give the coordinates of the gophers; the following m lines give the coordinates of the gopher holes. All distances are in metres; all times are in seconds; all velocities are in metres per second.

Output

Output consists of a single line for each case, giving the number of vulnerable gophers.

Sample Input

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

Sample Output

1

题意:就是有n个老鼠和m个洞,现在老鹰要抓老鼠,老鼠要逃到洞中。如果时间大于s则会被老鼠抓住,求老鹰抓的最少数的老鼠。

本题就一个简单的二分图,把洞离老鼠的距离小与s*v的当作一条边,即把老鼠看作一个集合,洞看作一个集合,现在就找边


代码:


#include<iostream>
#include<fstream>
#include<iomanip>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<cstdlib>
#include<cmath>
#include<set>
#include<map>
#include<queue>
#include<stack>
#include<string>
#include<vector>
#include<sstream>
#include<cassert>
using namespace std;
#define LL __int64
#define maxn 1500
#define eps 1e-6
struct point {
    double x,y;
};
point a[1500];
point b[1500];
double dis(point c,point d) {
    double ans=sqrt((c.x-d.x)*(c.x-d.x)+(c.y-d.y)*(c.y-d.y));
    return ans;
}

int n,m,s,v;
bool g[maxn][maxn];
int x[maxn],y[maxn];
bool chk[maxn];
bool searchpath(int u) {
    int v;
    for(v=1; v<=m+n; v++) {
        if(g[u][v]&&!chk[v]) {
            chk[v]=true;
            if(y[v]==-1||searchpath(y[v])) {
                y[v]=u;
                x[u]=v;
                return true;
            }
        }
    }
    return false;
}

int fun() {
    int u,res=0;
    memset(x,-1,sizeof(x));
    memset(y,-1,sizeof(y));
    for(u=1; u<=n; u++) {
        if(x[u]==-1) {
            memset(chk,false,sizeof(chk));
        }
        if(searchpath(u)) res++;
    }
    return res;
}


int main() {

    while(cin>>n>>m>>s>>v) {
        for(int i=1; i<=n; i++) {
            cin>>a[i].x>>a[i].y;
        }
        for(int i=1; i<=m; i++) {
            cin>>b[i].x>>b[i].y;
        }
        double di=(double)s*v;
        memset(g,false,sizeof(g));
        for(int i=1; i<=n; i++) {
            for(int j=1; j<=m; j++) {
                if(dis(a[i],b[j])<=di+eps) {
                    g[i][j]=true;
                }
            }
        }
        int aa=n-fun();
        cout<<aa<<endl;
    }
    return 0;
}
/*

2 2 5 10
1.0 1.0
2.0 2.0
100.0 100.0
20.0 20.0

*/




Stkcd [股票代码] ShortName [股票简称] Accper [统计截止日期] Typrep [报表类型编码] Indcd [行业代码] Indnme [行业名称] Source [公告来源] F060101B [净利润现金净含量] F060101C [净利润现金净含量TTM] F060201B [营业收入现金含量] F060201C [营业收入现金含量TTM] F060301B [营业收入现金净含量] F060301C [营业收入现金净含量TTM] F060401B [营业利润现金净含量] F060401C [营业利润现金净含量TTM] F060901B [筹资活动债权人现金净流量] F060901C [筹资活动债权人现金净流量TTM] F061001B [筹资活动股东现金净流量] F061001C [筹资活动股东现金净流量TTM] F061201B [折旧摊销] F061201C [折旧摊销TTM] F061301B [公司现金流1] F061302B [公司现金流2] F061301C [公司现金流TTM1] F061302C [公司现金流TTM2] F061401B [股权现金流1] F061402B [股权现金流2] F061401C [股权现金流TTM1] F061402C [股权现金流TTM2] F061501B [公司自由现金流(原有)] F061601B [股权自由现金流(原有)] F061701B [全部现金回收率] F061801B [营运指数] F061901B [资本支出与折旧摊销比] F062001B [现金适合比率] F062101B [现金再投资比率] F062201B [现金满足投资比率] F062301B [股权自由现金流] F062401B [企业自由现金流] Indcd1 [行业代码1] Indnme1 [行业名称1] 季度数据,所有沪深北上市公司的 分别包含excel、dta数据文件格式及其说明,便于不同软件工具对数据的分析应用 数据来源:基于上市公司年报及公告数据整理,或相关证券交易所、各部委、省、市数据 数据范围:基于沪深北证上市公司 A股(主板、中小企业板、创业板、科创板等)数据整理计算
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值