Message Flood oj 1500

 Problem Description

Well, how do you feel about mobile phone? Your answer would probably be something like that "It's so convenient and benefits people a lot". However, If you ask Merlin this question on the New Year's Eve, he will definitely answer "What a trouble! I have to keep my fingers moving on the phone the whole night, because I have so many greeting message to send!" Yes, Merlin has such a long name list of his friends, and he would like to send a greeting message to each of them. What's worse, Merlin has another long name list of senders that have sent message to him, and he doesn't want to send another message to bother them Merlin is so polite that he always replies each message he receives immediately). So, before he begins to send message, he needs to figure to how many friends are left to be sent. Please write a program to help him. Here is something that you should note. First, Merlin's friend list is not ordered, and each name is alphabetic strings and case insensitive. These names are guaranteed to be not duplicated. Second, some senders may send more than one message to Merlin, therefore the sender list may be duplicated. Third, Merlin is known by so many people, that's why some message senders are even not included in his friend list.

Input

There are multiple test cases. In each case, at the first line there are two numbers n and m (1<=n,m<=20000), which is the number of friends and the number of messages he has received. And then there are n lines of alphabetic strings(the length of each will be less than 10), indicating the names of Merlin's friends, one per line. After that there are m lines of alphabetic strings, which are the names of message senders. The input is terminated by n=0.

Output

For each case, print one integer in one line which indicates the number of left friends he must send.

Sample Input

5 3
Inkfish
Henry
Carp
Max
Jericho
Carp
Max
Carp
0

Sample Output

3

Hint

Source

第9届中山大学程序设计竞赛预选赛

题目是字符串哈希的联系, 没怎么用哈希

引用qsort, 写一个二分查找函数,

一开始输入n组的时候, 都标记a[i].f = 1, 后面m组中出现的 a[i].f = 0, 最后计算a[i].f = 1的num

#include <stdio.h>
#include <stdlib.h>
#include<string.h>
struct node
{
    char s[11];
    int f;
}a[20001];
int cmp(const void *a, const void *b)
{
    return strcmp( (char *)a, (char *)b);
}
void midfind(struct node a[], char *s2, int low, int high)
{
    int mid;
    while(low <= high)
    {
        mid = (low + high) / 2;
        if(strcmp(a[mid].s, s2) == 0)
        {
            a[mid].f = 0;
            break;
        }
        else if(strcmp(a[mid].s, s2) > 0)  // a[mid].s > s2
            high = mid -1;
        else
            low = mid+1;
    }
}
int main()
{
    int n, m, i, j, len;
    char s1[11], s2[11];
    while(~scanf("%d", &n) && n)
    {
        scanf("%d", &m);
        getchar();
        for(i = 0; i < n; i++)
        {
            gets(s1);
            len = strlen(s1);
            for(j = 0; j < len; j++)
            {
                if(s1[j] >= 'a')
                    s1[j] -= 32;
            }
            strcpy(a[i].s, s1);
            a[i].f = 1;
        }
        qsort(a, n, sizeof(a[0]), cmp);
        for(i = 0; i < m; i++)
        {
            gets(s2);
            len = strlen(s2);
            for(j = 0; j < len; j++)
            {
                if(s2[j] >= 'a')
                    s2[j] -= 32;
            }
            /*
            int low = 0, high = n - 1, mid;
            while(low <= high)
            {
                mid = (low + high) / 2;
                if(strcmp(a[mid].s, s2) == 0)
                {
                    a[mid].f = 0;
                    break;
                }
                else if(strcmp(a[mid].s, s2) > 0)  // a[mid].s > s2
                    high = mid -1;
                else
                    low = mid+1;
            }
            */
            midfind(a, s2, 0, n-1);
        }
        int num = 0;
        for(i = 0; i < n; i++)
        {
            if(a[i].f)
                num++;
        }
        printf("%d\n", num);
    }
    return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值