同余定理在阶乘和取余上的运用

21 篇文章 1 订阅

1254: GCC
Time Limit: 1 Sec Memory Limit: 128 MB
[Submit][Status][Web Board]
Description
The GNU Compiler Collection (usually shortened to GCC) is a compiler system produced by the GNU Project supporting various programming languages. But it doesn’t contains the math operator “!”.
In mathematics the symbol represents the factorial operation. The expression n! means “the product of the integers from 1 to n”. For example, 4! (read four factorial) is 4 × 3 × 2 × 1 = 24. (0! is defined as 1, which is a neutral element in multiplication, not multiplied by anything.)
We want you to help us with this formation: (0! + 1! + 2! + 3! + 4! + … + n!)%m

Input

The first line consists of an integer T, indicating the number of test cases.
Each test on a single consists of two integer n and m.

Output

Output the answer of (0! + 1! + 2! + 3! + 4! + … + n!)%m.

Constrains
0 < T <= 20
0 <= n < 10^100 (without leading zero)
0 < m < 1000000

Sample Input

1
10 861017

Sample Output

593846

HINT

Source

2009 Asia Wuhan Regional Contest Online
AC_code:
/*
只要n>m,那么m!+(m+1)!+…+n!这些项都是可以被m整除的,要对m求余,
只需要找比m小的阶乘。
so只需判断n是否大于m,若大于m,则n取m-1,若小于m则不变。
同时根据同余定理,只需算n!%m即可!
*/

#include <stdio.h>
#include <string.h>
char a[105];
int main()
{
    int T;
    scanf("%d",&T);
    while(T--)
    {
        memset(a,'\0',sizeof(a));
        int n = 0,m;
        scanf("%s %d",a,&m);
        long long sum = 1,l = strlen(a),num = 1;
        for(int i = 0; i < l; i++)
        {
            n = n*10 + (a[i]-'0');
            if(n >= m) break;
        }
        if(n >= m||l > 7) n = m-1;//当长度大于7或n>=m时只需算(m-1)!
        for(int i = 1; i <= n; i++)
        {
            num = num*i%m;
            sum = (sum+num)%m;
            if(num == 0) break;
        }
        printf("%lld\n",sum%m);//这里必须也要取余
    }
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值