1269: GPA-一题简单英文题~

//很好奇AC率为啥这么低
1269: GPA
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 1064 Solved: 320
[Submit][Status][Web Board]
Description

In college, a student may take several courses. For each course i, he earns a certain credit(ci), and a mark ranging from A to F, which is comparable to a score(si), according to the following conversion table

A B C D F

4.0 3.0 2.0 1.3 0

The GPA is the weighted average score of all courses one student may take, if we treat the credit as the weight. In other words,

An additional treatment is taken for special cases. Some courses are based on “Pass/Not pass” policy, where students earns a mark “P” for “Pass” and a mark “N” for “Not pass”. Such courses are not supposed to be considered in computation. These special courses must be ignored for computing the correct GPA.

Specially, if a student’s credit in GPA computation is 0, his/her GPA will be “0.00”

Input

There are several test cases, please process till EOF.

Each test case starts with a line containing one integer N (1<N<100), the number of courses. Then follow N lines, each consists the credit and the mark of one course. Credit is a positive integer and less than 10.

Output

For each test case, print the GPA (rounded to two decimal places) as the answer.

Sample Input

4
2 B
2 P
1 F
3 A
2
2 P
2 N
6
4 A
3 A
3 A
4 A
3 A
3 A

Sample Output

3.00
0.00
4.00

HINT

For the first test case:

P/N is not considered.

Source

FDU
ACcode~:

#include <stdio.h>
typedef struct gpa
{
    double c;
    char s;
}GPA;
int main()
{
    int n;
    while(~scanf("%d",&n))
    {
        GPA date[n];
        double sum = 0,num = 0,aver = 0;
        for(int i = 0; i < n; i++)
        {
            scanf("%lf %c",&date[i].c,&date[i].s);
            switch(date[i].s)
            {
                case 'A':sum += date[i].c*4.0;num += date[i].c;break;
                case 'B':sum += date[i].c*3.0;num += date[i].c;break;
                case 'C':sum += date[i].c*2.0;num += date[i].c;break;
                case 'D':sum += date[i].c*1.3;num += date[i].c;break;
                case 'F':num += date[i].c;break;
            }
        }
        if(sum)
          aver = sum / num;
        printf("%.2lf\n",aver);
    }
    return 0;
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值