1884: 三个家庭(思维题)

1884: 三个家庭
Time Limit: 1 Sec Memory Limit: 128 MB
Submit: 244 Solved: 81
[Submit][Status][Web Board]
Description

There are three families who have a garden, each wife of three families need to help clean the garden. Mrs. A worked for five days and Mrs. B worked for four days before finishing the garden. Mis. C is pregnant so she can’t join their work.In order to thank for their work,she paid 90 yuan .The question is how to give A,B the money , how much should A get? 90 / (5 + 4) * 5 = 50 yuan ? If you think so , how stupid you are ! The correct answer is 60 yuan . Please think about it carefully.
The following answer is a general question: assuming that Mrs. A worked for x days, Mrs. B worked for y days, Mrs. C had z yuan , how much should A wife get ? Two wives get non-negative integer money. Three wives have the same work efficiency.

Input

Multiple cases , for each case:
Three positive integers x,y,z . A wife worked for x days , B wife worked for y days , and C wife paid z yuan for them .

Output

For each case ,output a interger ,the money that A wife got. We needed to do decimals to round up and round down numbers。

Sample Input

5 4 90

Sample Output

60

HINT

Source

XF
AC_code:
/*
思维题,本来三个人应该做一样多的,现在A,B帮C做了她那份,看A帮C做了多少,注意这句话: We needed to do decimals to round up and round down numbers(我们需要做小数的四舍五入)。
*/

#include <stdio.h>
int main()
{
    double x,y,z;
    while(~scanf("%lf%lf%lf",&x,&y,&z))
    {
        double aver = (x + y)/3;
        double A_get;
        x > aver?A_get = (x - aver)*z/aver:A_get = 0;
        printf("%.0lf\n",A_get);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值