Longest Increasing Subsequence(LIS入门dp)

http://poj.org/problem?id=2533
Longest Ordered Subsequence
Time Limit: 2000MS Memory Limit: 65536K

Description

A numeric sequence of ai is ordered if a1 < a2 < … < aN. Let the subsequence of the given numeric sequence (a1, a2, …, aN) be any sequence (ai1, ai2, …, aiK), where 1 <= i1 < i2 < … < iK <= N. For example, sequence (1, 7, 3, 5, 9, 4, 8) has ordered subsequences, e. g., (1, 7), (3, 4, 8) and many others. All longest ordered subsequences are of length 4, e. g., (1, 3, 5, 8).

Your program, when given the numeric sequence, must find the length of its longest ordered subsequence.
Input

The first line of input file contains the length of sequence N. The second line contains the elements of sequence - N integers in the range from 0 to 10000 each, separated by spaces. 1 <= N <= 1000
Output

Output file must contain a single integer - the length of the longest ordered subsequence of the given sequence.
Sample Input

7
1 7 3 5 9 4 8
Sample Output

4
/*

裸的LIS问题:
对于LIS做dp,

下面是根据我的理解写的求解步骤,不足之处欢迎指出

    1.确定最优状态:
    设dp[i]为序列数组中i位置上的最优状态
    
    2. 考虑如何达到最优状态:
    即dp[i]是怎么出来的,对于i位置的最优状态是由i之前的(设为j,0...j < i)最大dp[j]得来的,
    如果a[i] > a[j],那么dp[i] = max(dp[0...j])+1
    否则dp[i] = max(dp[0...j])
    
    3.由2推出状态转移方程:
    dp[i] = max(dp[j]+1,dp[i])(0..j,j<i&&a[i]>a[j])
    
    4.考虑边界:
    在未dp前,对于每单独的一个数,dp[i] = 1;
    
    5.write code...

*/
AC_code:

#include <iostream>
using namespace std;
int dp[1005],a[1005];
 int main()
 {
     int n;
     cin>>n;
     for(int i = 0; i < n; i++)
     {
         cin>>a[i];
         dp[i] = 1;
     }
     int ans = 0;
     for(int i = 0; i <n; i++)
     {
         for(int j = 0; j < i; j++)
         {
             if(a[i] > a[j])
             {
                 dp[i] = max(dp[j]+1,dp[i]);
             }
         }
         ans = max(ans,dp[i]);
     }
     cout<<ans<<endl;
     return 0;
 }
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Leo Bliss

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值