B - Euclid's Game
Two players, Stan and Ollie, play, starting with two natural numbers. Stan, the first player, subtracts any positive multiple of the lesser of the two numbers from the greater of the two numbers, provided that the resulting number must be nonnegative. Then Ollie, the second player, does the same with the two resulting numbers, then Stan, etc., alternately, until one player is able to subtract a multiple of the lesser number from the greater to reach 0, and thereby wins. For example, the players may start with (25,7):
25 7
11 7
4 7
4 3
1 3
1 0
an Stan wins.
Input
The input consists of a number of lines. Each line contains two positive integers giving the starting two numbers of the game. Stan always starts.
Output
For each line of input, output one line saying either Stan wins or Ollie wins assuming that both of them play perfectly. The last line of input contains two zeroes and should not be processed.
Sample Input
34 12 15 24 0 0
Sample Output
Stan wins Ollie wins
题意:
就不多说了。设这两个数——小数为a,大数为b。
思路:
找规律。
当b>=a*2 || b==a时,stan赢。
当b<a*2 时,模拟相减,判断 谁赢。
代码:
#include<string>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
#define mem(a,b) memset(a,b,sizeof(a))
void swa(int &x,int &y)
{
int t;
t=x;
x=y;
y=t;
}
int main()
{
int s,o;
while(~scanf("%d%d",&s,&o)&&(s||o))
{
if(s>o)
swa(s,o);
bool flag=true;
while(1)
{
if(o%s==0 || o>=s*2)
break;
o-=s;
swa(s,o);
flag=!flag;
}
if(flag)
printf("Stan wins\n");
else
printf("Ollie wins\n");
}
return 0;
}