hdoj1710Binary Tree Traversals

Binary Tree Traversals

Time Limit: 1000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1406    Accepted Submission(s): 655


Problem Description
A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2.

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder.

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder.

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.

Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.

Output
For each test case print a single line specifying the corresponding postorder sequence.

Sample Input
  
  
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6

Sample Output
  
  
7 4 2 8 9 5 6 3 1

Source

Recommend
lcy
 
 本质就是知道二叉树的前序和中序求后序
 

#include <iostream>
#include <algorithm>

using namespace std;
int preorder[1005];
int inorder[1005];

void dfs(int pre,int in,int size,bool flag)
{
    int i;
    if(size==1) //如果有左子树或右子树,就直接输出
    {
        printf("%d ",preorder[pre]); 
        return ;
    }
    if(size<=0) //没有左子树或右子树,则返回上层,遍历右子树或者根
        return ;
    for(i=0;preorder[pre]!=inorder[in+i];i++);//查找根节点在中序中的位置
    dfs(pre+1,in,i,false);              //左子树的遍历
    dfs(pre+i+1,in+i+1,size-i-1,false); //右子树的遍历
    if(flag)                           //输出根节点
        printf("%d\n",preorder[pre]);  //整个树的根节点
    else
        printf("%d ",preorder[pre]);   //一般的根节点
}

int main()
{
    int n,i;
    while(cin>>n)
    {
        for(i=1;i<=n;i++)
            scanf("%d",&preorder[i]);
        for(i=1;i<=n;i++)
            scanf("%d",&inorder[i]);
        dfs(1,1,n,true);
    }
    return 0;
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值