In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r.
Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence.
Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree.
Output
For each test case print a single line specifying the corresponding postorder sequence.
Sample Input
9 1 2 4 7 3 5 8 9 6 4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1
题解:给出前序遍历和中序遍历,求后序遍历。
#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
int s1[1010],s2[10010],mp[10010],ans;
void dfs(int l,int *s1,int *s2)
{
if(l<=0)
return ;
mp[ans++]=s1[0];
int t;
for(t=0; s2[t]!=s1[0]; t++);
dfs(l-1-t,s1+t+1,s2+t+1);
dfs(t,s1+1,s2);
}
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j;
ans=0;
for(i=0; i<n; i++)
scanf("%d",&s1[i]);
for(i=0; i<n; i++)
scanf("%d",&s2[i]);
dfs(n,s1,s2);
for(i=n-1; i>0; i--)
printf("%d ",mp[i]);
printf("%d\n",mp[0]);
}
return 0;
}