HDU-Binary Tree Traversals

A binary tree is a finite set of vertices that is either empty or consists of a root r and two disjoint binary trees called the left and right subtrees. There are three most important ways in which the vertices of a binary tree can be systematically traversed or ordered. They are preorder, inorder and postorder. Let T be a binary tree with root r and subtrees T1,T2. 

In a preorder traversal of the vertices of T, we visit the root r followed by visiting the vertices of T1 in preorder, then the vertices of T2 in preorder. 

In an inorder traversal of the vertices of T, we visit the vertices of T1 in inorder, then the root r, followed by the vertices of T2 in inorder. 

In a postorder traversal of the vertices of T, we visit the vertices of T1 in postorder, then the vertices of T2 in postorder and finally we visit r. 

Now you are given the preorder sequence and inorder sequence of a certain binary tree. Try to find out its postorder sequence. 
Input
The input contains several test cases. The first line of each test case contains a single integer n (1<=n<=1000), the number of vertices of the binary tree. Followed by two lines, respectively indicating the preorder sequence and inorder sequence. You can assume they are always correspond to a exclusive binary tree. 
Output
For each test case print a single line specifying the corresponding postorder sequence. 
Sample Input
9
1 2 4 7 3 5 8 9 6
4 7 2 1 8 5 9 3 6
Sample Output
7 4 2 8 9 5 6 3 1
#include<stdio.h>
//由先序中序推后序,两序推一序必须要有中序	
int pre[1005],in[1005];
struct node{
	int data;
	node* ltree;
	node* rtree;
}; 
node* buildtree(int prel,int prer,int inl,int inr)//4个参数  先序的左右边界,中序的左右边界 
{
	int i;
	if(prel>prer)
	return NULL;
	node* root=new node;//建立一个根结点,用来存放当前的树
	root->data=pre[prel];// 因为是已知先序,所以当前树的值,一定等于先序的最左边的点 
	for( i=inl;i<=inr;i++)//记录当前根节点在中序的位置
	{
		if(pre[prel]==in[i])
		break; 
	}
	int num=i-inl;
	root->ltree=buildtree(prel+1,prel+num,inl,inl+num-1);//将这部分存入左子树 
    root->rtree=buildtree(prel+num+1,prer,inl+num+1,inr);// 将这部分存入右子树
    return root;//返回根结点的地址 
}
int t;
void printfpost(node* root)
{
	if(root==NULL)
	return;
	printfpost(root->ltree);
	printfpost(root->rtree);
	t++;
	if(t==1)
	printf("%d",root->data);
	else
	printf(" %d",root->data);
}
int main()
{
   int n,i;
	while(~scanf("%d",&n))
	{
		t=0;
		for(i=1;i<=n;i++)
		scanf("%d",&pre[i]);
		for(i=1;i<=n;i++)
		scanf("%d",&in[i]);
		node* root=buildtree(1,n,1,n);
		printfpost(root);
		printf("\n");
	}
}

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值