hdu2126(变形01背包,求方案数)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=2126

Buy the souvenirs

Time Limit: 10000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 612    Accepted Submission(s): 199


Problem Description
When the winter holiday comes, a lot of people will have a trip. Generally, there are a lot of souvenirs to sell, and sometimes the travelers will buy some ones with pleasure. Not only can they give the souvenirs to their friends and families as gifts, but also can the souvenirs leave them good recollections. All in all, the prices of souvenirs are not very dear, and the souvenirs are also very lovable and interesting. But the money the people have is under the control. They can’t buy a lot, but only a few. So after they admire all the souvenirs, they decide to buy some ones, and they have many combinations to select, but there are no two ones with the same kind in any combination. Now there is a blank written by the names and prices of the souvenirs, as a top coder all around the world, you should calculate how many selections you have, and any selection owns the most kinds of different souvenirs. For instance:



And you have only 7 RMB, this time you can select any combination with 3 kinds of souvenirs at most, so the selections of 3 kinds of souvenirs are ABC (6), ABD (7). But if you have 8 RMB, the selections with the most kinds of souvenirs are ABC (6), ABD (7), ACD (8), and if you have 10 RMB, there is only one selection with the most kinds of souvenirs to you: ABCD (10).
 

Input
For the first line, there is a T means the number cases, then T cases follow.
In each case, in the first line there are two integer n and m, n is the number of the souvenirs and m is the money you have. The second line contains n integers; each integer describes a kind of souvenir. 
All the numbers and results are in the range of 32-signed integer, and 0<=m<=500, 0<n<=30, t<=500, and the prices are all positive integers. There is a blank line between two cases.
 

Output
If you can buy some souvenirs, you should print the result with the same formation as “You have S selection(s) to buy with K kind(s) of souvenirs”, where the K means the most kinds of souvenirs you can buy, and S means the numbers of the combinations you can buy with the K kinds of souvenirs combination. But sometimes you can buy nothing, so you must print the result “Sorry, you can't buy anything.”
 

Sample Input
  
  
2 4 7 1 2 3 4 4 0 1 2 3 4
 

Sample Output
  
  
You have 2 selection(s) to buy with 3 kind(s) of souvenirs. Sorry, you can't buy anything.
 

题意:求出买最多个物品的方案数。

思路:因为要求方案数,所以优先想到搜索,但搜索超时了。

            先到多开一维来记录方案数。

            例如:对于第一组测试数据:

                  i:                    0    1    2    3    4    5    6    7

            方案数:dp[0][i]   1    1    1    1    1    2    1    1

            物品数:dp[1][i]   0    1    1    2    2    2    3    3

            让0位置的方案数记为1,然后遇到相同的加上,遇到大于的就替换掉。

            具体注意事项见代码。

代码:

#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
int vol[40],dp[2][510],ans1,ans2;
int main()
{
    int n,v,i,j,t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));dp[1][0]=1;
        scanf("%d%d",&n,&v);
        for(i=1;i<=n;i++) scanf("%d",&vol[i]);
        for(i=1;i<=n;i++)
        {
            for(j=v;j>=vol[i];j--)
            {
                if(dp[0][j-vol[i]]+1>dp[0][j])
                {
                    dp[0][j]=dp[0][j-vol[i]]+1;
                    dp[1][j]=dp[1][j-vol[i]];  //同种体积得到的物品数比原来大的话就替换方案数
                }
                else if(dp[0][j-vol[i]]+1==dp[0][j])
                    dp[1][j]+=dp[1][j-vol[i]];  //同种体积得到的物品数和原来的物品数相等的话就加上方案数
            }
        }
        ans1=dp[1][v];ans2=v;
        while(dp[0][ans2]==dp[0][ans2-1]) ans1+=dp[1][--ans2];  //需要注意的是:最大的物品数不一定就在满容积时得到,就比如第一组测试数据6、7是均可买得3种物品
        if(!dp[0][v]) printf("Sorry, you can't buy anything.\n");
        else printf("You have %d selection(s) to buy with %d kind(s) of souvenirs.\n",ans1,dp[0][v]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值