hdu1011(树形背包)

地址:http://acm.hdu.edu.cn/showproblem.php?pid=1011

Starship Troopers

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 10508    Accepted Submission(s): 2875


Problem Description
You, the leader of Starship Troopers, are sent to destroy a base of the bugs. The base is built underground. It is actually a huge cavern, which consists of many rooms connected with tunnels. Each room is occupied by some bugs, and their brains hide in some of the rooms. Scientists have just developed a new weapon and want to experiment it on some brains. Your task is to destroy the whole base, and capture as many brains as possible.

To kill all the bugs is always easier than to capture their brains. A map is drawn for you, with all the rooms marked by the amount of bugs inside, and the possibility of containing a brain. The cavern's structure is like a tree in such a way that there is one unique path leading to each room from the entrance. To finish the battle as soon as possible, you do not want to wait for the troopers to clear a room before advancing to the next one, instead you have to leave some troopers at each room passed to fight all the bugs inside. The troopers never re-enter a room where they have visited before.

A starship trooper can fight against 20 bugs. Since you do not have enough troopers, you can only take some of the rooms and let the nerve gas do the rest of the job. At the mean time, you should maximize the possibility of capturing a brain. To simplify the problem, just maximize the sum of all the possibilities of containing brains for the taken rooms. Making such a plan is a difficult job. You need the help of a computer.
 

Input
The input contains several test cases. The first line of each test case contains two integers N (0 < N <= 100) and M (0 <= M <= 100), which are the number of rooms in the cavern and the number of starship troopers you have, respectively. The following N lines give the description of the rooms. Each line contains two non-negative integers -- the amount of bugs inside and the possibility of containing a brain, respectively. The next N - 1 lines give the description of tunnels. Each tunnel is described by two integers, which are the indices of the two rooms it connects. Rooms are numbered from 1 and room 1 is the entrance to the cavern.

The last test case is followed by two -1's.
 

Output
For each test case, print on a single line the maximum sum of all the possibilities of containing brains for the taken rooms.
 

Sample Input
  
  
5 10 50 10 40 10 40 20 65 30 70 30 1 2 1 3 2 4 2 5 1 1 20 7 -1 -1
 

Sample Output
  
  
50 7
 

题意:有n个节点的树,每个节点有Ai个BUG和Bi价值,你有m个士兵,每个士兵只能打败20个BUG,且士兵使用过不能再用第二次,想访问子节点必须先将其父亲节点的BUG全部消灭,问最大可以得到的价值。

思路:最开始是想直接背包,但这样就没办法符合第二个条件:想访问子节点必先将父亲节点的BUG消灭。后来将要访问的子节点的BUG与父亲节点的BUG结合一下,相当于将两个节点合成一个节点,付出的与收获的也变成两个节点的和,但一个父亲节点不只有一个子节点。最后还是看了下别人的代码过的,始终没有想通的地方是对一串消耗为零的节点,必须派一个士兵去,这里怎么实现。

代码:

#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
#define Ma 110
#define INF 0xfffffff
#define LL __int64
struct node{
    int to,next;
}tree[Ma*2];
int n,m,len,head[Ma],los[Ma],get[Ma],dp[Ma][Ma];
void add(int no,int to){
    tree[len].to=to;
    tree[len].next=head[no];
    head[no]=len++;
}
void dfs(int no,int pa){
    for(int i=los[no];i<=m;i++) dp[no][i]=get[no];  //初始化当前节点的dp数组,从los值开始
    for(int i=head[no];i!=-1;i=tree[i].next){
        int to=tree[i].to;
        if(to==pa) continue;
        dfs(to,no);
        for(int j=m;j>los[no];j--)
            for(int k=1;k<=j-los[no];k++)  //k始终从1开始,表示至少派一个士兵去子节点
                dp[no][j]=max(dp[no][j],dp[no][j-k]+dp[to][k]);
    }
}
int main(){
    while(scanf("%d%d",&n,&m)>0){
        if(m<0&&n<0) break;  //不知道为啥用~m,~n就WA
        memset(head,-1,sizeof(head));
        memset(dp,0,sizeof(dp));
        len=0;
        for(int i=1;i<=n;i++){
            scanf("%d%d",&los[i],&get[i]);
            los[i]=(los[i]+19)/20;  //los的值转换为对应的士兵数
        }
        for(int i=1;i<n;i++){
            int l,r;
            scanf("%d%d",&l,&r);
            add(l,r);
            add(r,l);
        }
        if(!m) {puts("0");continue;}  //当m为0时,特判
        dfs(1,-1);
        printf("%d\n",dp[1][m]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值