uva 10004 Bicoloring 二染色

原题:
In 1976 the “Four Color Map Theorem” was proven with the assistance of a computer. This theorem
states that every map can be colored using only four colors, in such a way that no region is colored
using the same color as a neighbor region.
Here you are asked to solve a simpler similar problem. You have to decide whether a given arbitrary
connected graph can be bicolored. That is, if one can assign colors (from a palette of two) to the nodes
in such a way that no two adjacent nodes have the same color. To simplify the problem you can assume:
• no node will have an edge to itself.
• the graph is nondirected. That is, if a node a is said to be connected to a node b, then you must
assume that b is connected to a.
• the graph will be strongly connected. That is, there will be at least one path from any node to
any other node.
Input
The input consists of several test cases. Each test case starts with a line containing the number n
(1 < n < 200) of different nodes. The second line contains the number of edges l. After this, l lines will
follow, each containing two numbers that specify an edge between the two nodes that they represent.
A node in the graph will be labeled using a number a (0 ≤ a < n).
An input with n = 0 will mark the end of the input and is not to be processed.
Output
You have to decide whether the input graph can be bicolored or not, and print it as shown below.
Sample Input
3
3
0 1
1 2
2 0
3
2
0 1
1 2
9
8
0 1
0 2
0 3
0 4
0 5
0 6
0 7
Universidad de Valladolid OJ: 10004 – Bicoloring
2/2
0 8
0
Sample Output
NOT BICOLORABLE.
BICOLORABLE.
BICOLORABLE.
题目大意:
先介绍了四色定理,然后说现在给你一个更简单的问题。给你一个无向图,问你能否用两种颜色把整个图染色,其中要求相邻的两个节点的颜色是不同的。

#include<iostream>
#include<algorithm>
#include<vector>
#include<string>
#include<cstring>
using namespace std;
int color[201];
int n,e;
vector<int> edge[201];//邻接表
bool dfs(int x,int k)
{
    color[x]=k%2;
    for(int i=0;i<edge[x].size();i++)
    {
        int tmp=edge[x][i];
        if(color[x]==color[tmp])//当前的节点和它相邻的节点颜色相同
            return false;//如果相同就说明无法染色
        else
        {
            if(color[tmp]==-1)//-1代表这个节点还没有染色
            {
                if(dfs(tmp,k+1))//把这个节点染了
                return true;//染色成功就返回true
                else
                return false;//染不了就false
            }
        }
    }
    return true;
}
int main()
{
    ios::sync_with_stdio(false);
    int a,b;
    while(cin>>n)
    {
        if(n==0)
        return 0;
        cin>>e;
        for(int i=0;i<201;i++)
        edge[i].clear();
        for(int i=0;i<e;i++)
        {
            cin>>a>>b;
            edge[a].push_back(b);
            edge[b].push_back(a);
        }
        memset(color,-1,sizeof(color));
        if(dfs(a,0))
        cout<<"BICOLORABLE."<<endl;
        else
        cout<<"NOT BICOLORABLE."<<endl;
    }
    return 0;
}








思路:
就是一个二分图染色的问题,深度优先搜索这个图,以此给节点染色判断相邻的节点是否颜色相同即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值