uva 571 Jugs

原题:
In the movie “Die Hard 3”, Bruce Willis and Samuel L. Jackson were confronted with the following puzzle. They were given a 3-gallon jug and a 5-gallon jug and were asked to fill the 5-gallon jug with exactly 4 gallons. This problem generalizes that puzzle.

You have two jugs, A and B, and an infinite supply of water. There are three types of actions that you can use: (1) you can fill a jug, (2) you can empty a jug, and (3) you can pour from one jug to the other. Pouring from one jug to the other stops when the first jug is empty or the second jug is full, whichever comes first. For example, if A has 5 gallons and B has 6 gallons and a capacity of 8, then pouring from A to B leaves B full and 3 gallons in A.

A problem is given by a triple (Ca,Cb,N), where Ca and Cb are the capacities of the jugs A and B, respectively, and N is the goal. A solution is a sequence of steps that leaves exactly N gallons in jug B. The possible steps are

fill A
fill B
empty A
empty B
pour A B
pour B A
success
where pour A B" meanspour the contents of jug A into jug B”, and “success” means that the goal has been accomplished.

You may assume that the input you are given does have a solution.

Input

Input to your program consists of a series of input lines each defining one puzzle. Input for each puzzle is a single line of three positive integers: Ca, Cb, and N. Ca and Cb are the capacities of jugs A and B, and N is the goal. You can assume 0 < Ca< Cb and N < Cb <1000 and that A and B are relatively prime to one another.
Output

Output from your program will consist of a series of instructions from the list of the potential output lines which will result in either of the jugs containing exactly N gallons of water. The last line of output for each puzzle should be the line “success”. Output lines start in column 1 and there should be no empty lines nor any trailing spaces.
Sample Input

3 5 4
5 7 3
Sample Output

fill B
pour B A
empty A
pour B A
fill B
pour B A
success
fill A
pour A B
fill A
pour A B
empty B
pour A B
success
大意:
给你两个壶a,b还有一个目标水量c。现在让你用a,b和无限的水倒出目标水量。其中a,b互质。

#include<iostream>
#include<algorithm>
#include<map>
#include<string>
#include<cstring>
#include<sstream>
#include<cstdio>
#include<vector>
#include<cmath>
#include<stack>
#include<queue>
#include<iomanip>
#include<set>
#include<fstream>
#include <climits>
using namespace std;
//fstream input,output;


int main()
{
    ios::sync_with_stdio(false);
    int ja,jb,aim;
    int a,b;
    while(cin>>ja>>jb>>aim)
    {
        if(ja==aim)
        {
            cout<<"fill A"<<endl;
            cout<<"success"<<endl;
            continue;
        }
        if(jb==aim)
        {
            cout<<"fill B"<<endl;
            cout<<"success"<<endl;
            continue;
        }
        a=b=0;
        while(b!=aim)
        {
            if(a==0)
            {
                cout<<"fill A"<<endl;
                a=ja;
            }
            if(b<jb)
            {
                cout<<"pour A B"<<endl;
                if(b+ja>jb)
                {
                    a=ja-(jb-b);
                    b=jb;
                }
                else
                {
                    b+=a;
                    a=0;
                }
            }
            if(b==jb)
            {
                cout<<"empty B"<<endl;
                b=0;
                cout<<"pour A B"<<endl;
                b=a;
                a=0;
            }
        }
        cout<<"success"<<endl;
    }
//  input.close();
//  output.close();
    return 0;
}




解答:
很经典的一个问题,刚读题的时候还以为让我判断能否倒出目标水量来,结果却是让我求操作方法。
首先先说明一下对任意给定的两个数a,b能否实现操作出目标c。现在假设b大于a,首先让a里的水装满不断倒进b中,直到b中的水装满。此时a里剩下的水是x,再把b里的水倒空,把x装进b中,不断重复就能发现这是一个经典的操作——更相减损的方法。也就是求最大公约数的方法。所以只要c的数量能够除开a与b的最大公约数就能够倒出目标水量,同时要求目标水量要小于b。

读完题后纠结了好长时间如何处理最少操作步骤,设a往b的里装水操作x,b往a里装水是y。则能得到,ax+by=1这样一个方程,再利用扩展欧几里得公式求出一组x,y的解,然后求得最小的x或者y….
后来想不出程序该怎么写了,看别人的题解居然发现任意一组解就可以….CNM的!

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值