uva 542 France '98

原题:
Today the first round of the Soccer World Championship in France is coming to an end. 16 countries are remaining now, among which the winner is determined by the following tournament:

1 Brazil —–+
+– ? –+
2 Chile ——+ |
+– ? –+
3 Nigeria —-+ | |
+– ? –+ |
4 Denmark —-+ |
+– ? –+
5 Holland —-+ | |
+– ? –+ | |
6 Yugoslavia -+ | | |
+– ? –+ |
7 Argentina –+ | |
+– ? –+ |
8 England —-+ |
+– World Champion
9 Italy ——+ |
+– ? –+ |
10 Norway —–+ | |
+– ? –+ |
11 France —–+ | | |
+– ? –+ | |
12 Paraguay —+ | |
+– ? –+
13 Germany —-+ |
+– ? –+ |
14 Mexico —–+ | |
+– ? –+
15 Romania —-+ |
+– ? –+
16 Croatia —-+
For each possible match A vs. B between these 16 nations, you are given the probability that team A wins against B. This (together with the tournament mode displayed above) is sufficient to compute the probability that a given nation wins the World Cup. For example, if Germany wins against Mexico with 80%, Romania against Croatia with 60%, Germany against Romania with 70% and Germany against Croatia with 90%, then the probability that Germany reaches the semi-finals is 80% * (70% * 60% + 90% * 40%) = 62.4%.

Your task is to write a program that computes the chances of the 16 nations to become the World Champion ‘98.

Input

The input file will contain just one test case.
The first 16 lines of the input file give the names of the 16 countries, from top to bottom according to the picture given above.

Next, there will follow a 16 × 16 integer matrix P where element pij gives the probability in percent that country #i defeats country #j in a direct match. Country #i means the i-th country from top to bottom given in the list of countries. In the picture above Brazil is #1 and Germany is #13, so p1,13 = 55 would mean that in a match between Brazil and Germany, Brazil wins with a probability of 55%.

Note that matches may not end with a draw, i.e. pij + pji = 100 for all i,j.

Output

Output 16 lines of the form “ XXXXXXXXXX p=Y.YY%”, where XXXXXXXXXX is the country’s name, left-justified in a field of 10 characters, and Y.YY is their chance in percent to win the cup, written to two decimal places. Use the same order of countries like in the input file.
Sample Input

Brazil
Chile
Nigeria
Denmark
Holland
Yugoslavia
Argentina
England
Italy
Norway
France
Paraguay
Germany
Mexico
Romania
Croatia
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
35 50 35 45 40 35 35 50 30 40 25 40 25 40 35 35
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
40 55 40 50 45 40 40 55 35 45 30 45 30 45 40 40
45 60 45 55 50 45 45 60 40 50 35 50 35 50 45 45
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
35 50 35 45 40 35 35 50 30 40 25 40 25 40 35 35
55 70 55 65 60 55 55 70 50 60 45 60 45 60 55 55
45 60 45 55 50 45 45 60 40 50 35 50 35 50 45 45
60 75 60 70 65 60 60 75 55 65 50 65 50 65 60 60
45 60 45 55 50 45 45 60 40 50 35 50 35 50 45 45
60 75 60 70 65 60 60 75 55 65 50 65 50 65 60 60
45 60 45 55 50 45 45 60 40 50 35 50 35 50 45 45
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
50 65 50 60 55 50 50 65 45 55 40 55 40 55 50 50
Sample Output

Brazil p=8.54%
Chile p=1.60%
Nigeria p=8.06%
Denmark p=2.79%
Holland p=4.51%
Yugoslavia p=7.50%
Argentina p=8.38%
England p=1.56%
Italy p=9.05%
Norway p=3.23%
France p=13.72%
Paraguay p=3.09%
Germany p=13.79%
Mexico p=3.11%
Romania p=5.53%
Croatia p=5.53%
大意:
给你16个国家和16个国家中任意一个战胜其他国家的概率。问你最后每个国家获得冠军的概率。

#include <bits/stdc++.h>
using namespace std;
char country[17][17];
double win[17][17];
double two[17],four[17],eight[17],sixteen[17];
int main()
{
//  ios::sync_with_stdio(false);
    while(~scanf("%s",country[1]))
    {
        for(int i=2;i<=16;i++)
            scanf("%s",country[i]);
        for(int i=1;i<=16;i++)
        {
            for(int j=1;j<=16;j++)
            {
                double p;
                scanf("%lf",&p);
                win[i][j]=p/100.00;
            }
        }
        for(int i=2;i<=16;i+=2)//计算出2人赛
        {
            two[i-1]=win[i-1][i];
            two[i]=win[i][i-1];
        }
        for(int i=4;i<=16;i+=4)//计算出4人赛
        {
            four[i-3]=two[i-3]*(win[i-3][i-1]*two[i-1]+win[i-3][i]*two[i]);
            four[i-2]=two[i-2]*(win[i-2][i-1]*two[i-1]+win[i-2][i]*two[i]);
            four[i-1]=two[i-1]*(win[i-1][i-3]*two[i-3]+win[i-1][i-2]*two[i-2]);
            four[i]=two[i]*(win[i][i-3]*two[i-3]+win[i][i-2]*two[i-2]);
        }
        for(int i=1;i<=16;i++)//计算出8人赛
        {
            if(i>=1&&i<=4)
            {
                double tmp=0;
                for(int j=5;j<=8;j++)
                    tmp+=win[i][j]*four[j];
                eight[i]=four[i]*tmp;
            }
            if(i>=5&&i<=8)
            {
                double tmp=0;
                for(int j=1;j<=4;j++)
                    tmp+=win[i][j]*four[j];
                eight[i]=four[i]*tmp;
            }
            if(i>=9&&i<=12)
            {
                double tmp=0;
                for(int j=13;j<=16;j++)
                    tmp+=win[i][j]*four[j];
                eight[i]=four[i]*tmp;
            }
            if(i>=13&&i<=16)
            {
                double tmp=0;
                for(int j=9;j<=12;j++)
                    tmp+=win[i][j]*four[j];
                eight[i]=four[i]*tmp;
            }
        }
        for(int i=1;i<=16;i++)//计算出16人赛
        {
            if(i>=1&&i<=8)
            {
                double tmp=0;
                for(int j=9;j<=16;j++)
                    tmp+=win[i][j]*eight[j];
                sixteen[i]=tmp*eight[i];
            }
            if(i>=9&&i<=16)
            {
                double tmp=0;
                for(int j=1;j<=8;j++)
                    tmp+=win[i][j]*eight[j];
                sixteen[i]=tmp*eight[i];
            }
        }
        for(int i=1;i<=16;i++)
            printf("%-10s p=%.2f%\n",country[i],sixteen[i]*100);
        //  cout<<country[i]<<setw(10)<<"p="<<setprecision(2)<<fixed<<sixteen[i]*100.0<<"%"<<endl;
    }
    return 0;
}






解答:
明显的条件概率,而且题目中有算法提示。其中two,four,eight以及sixteen分别代表小组赛获胜的概率。
最后输出sixteen[i]即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值