uva 714 Copying Books

原题:
Before the invention of book-printing, it was very hard to make a copy of a book. All the contents had
to be re-written by hand by so called scribers. The scriber had been given a book and after several
months he finished its copy. One of the most famous scribers lived in the 15th century and his name
was Xaverius Endricus Remius Ontius Xendrianus (Xerox). Anyway, the work was very annoying and
boring. And the only way to speed it up was to hire more scribers.
Once upon a time, there was a theater ensemble that wanted to play famous Antique Tragedies. The
scripts of these plays were divided into many books and actors needed more copies of them, of course.
So they hired many scribers to make copies of these books. Imagine you have m books (numbered
1,2,…,m) that may have different number of pages (p1,p2,…,pm) and you want to make one copy of
each of them. Your task is to divide these books among k scribes, k ≤ m. Each book can be assigned
to a single scriber only, and every scriber must get a continuous sequence of books. That means, there
exists an increasing succession of numbers 0 = b0< b1< b2,… < bk−1≤ bk= m such that i-th scriber
gets a sequence of books with numbers between bi−1+ 1 and bi. The time needed to make a copy of
all the books is determined by the scriber who was assigned the most work. Therefore, our goal is to
minimize the maximum number of pages assigned to a single scriber. Your task is to find the optimal
assignment.
Input
The input consists of N cases. The first line of the input contains only positive integer N. Then follow
the cases. Each case consists of exactly two lines. At the first line, there are two integers m and k,
1 ≤ k ≤ m ≤ 500. At the second line, there are integers p1,p2,…,pmseparated by spaces. All these
values are positive and less than 10000000.
Output
For each case, print exactly one line. The line must contain the input succession p1,p2,…pmdivided
into exactly k parts such that the maximum sum of a single part should be as small as possible. Use
the slash character (‘/’) to separate the parts. There must be exactly one space character between any
two successive numbers and between the number and the slash.
If there is more than one solution, print the one that minimizes the work assigned to the first scriber,
then to the second scriber etc. But each scriber must be assigned at least one book.
Sample Input
2
9 3
100 200 300 400 500 600 700 800 900
5 4
100 100 100 100 100
Sample Output
100 200 300 400 500 / 600 700 / 800 900
100 / 100 / 100 / 100 100

大意:
给你n本书,和k个手抄员,让你把这些书分给这些人。最后计算的时间是最后一个人抄完的用时。现在让你求最后一个人抄完的最小时间。(按给定的顺序来,不能排序!!!)

#include <bits/stdc++.h>
using namespace std;

long long m,k,tot;
int a[510],mark[510];
bool solve(long long index,int kk)//在限定值index下是否满足条件
{
    long long tmp=0;
    for(int i=0;i<m;i++)
    {
        if(a[i]>index)
            return false;
        if(kk==1)
        {
            tmp=0;
            for(int j=i;j<m;j++)
                tmp+=a[j];
            if(tmp<=index)
                return true;
            else
                return false;
        }
        if(tmp+a[i]<=index)
        tmp+=a[i];
        else
        {
            kk--;
            tmp=0;
            i--;
        }
    }
    return true;
}
int main()
{
    ios::sync_with_stdio(false);
    long long t,tmp,seg;
    long long l,r,mid;
    cin>>t;
    while(t--)
    {
        tmp=tot=0;
        memset(mark,0,sizeof(mark));
        cin>>m>>k;
        for(int i=0;i<m;i++)
        {
            cin>>a[i];
            tot+=a[i];
        }
        if(k==1)
        {
            for(int i=0;i<m;i++)
                if(i!=m-1)
                    cout<<a[i]<<" ";
                else
                    cout<<a[i]<<endl;
            continue;
        }
        l=0;r=tot;
        while(r-l>1)
        {
            mid = (l+r)/2;
            if(solve(mid,k))
                r=mid;
            else
                l=mid;
        }
        seg=l+1;
//      cout<<seg<<endl;
        int q=1;
        tmp=0;
        for(int i=m-1;i>=0;i--)
        {
            if(tmp+a[i]>seg)
            {
                mark[i]=1;
                tmp = a[i];
                q++;
            }
            else
                tmp+=a[i];
            if(k-q==i+1)
            {
                for(int j=0;j<=i;j++)
                    mark[j]=1;
                break;
            }
        }
        for(int i=0;i<m-1;i++)
        {
            cout<<a[i]<<" ";
            if(mark[i])
                cout<<'/'<<" ";
        }
        cout<<a[m-1]<<endl;
    }
    return 0;
}

解答:
最大化最小值,最小化最大值,或者是最大,最小化平均值一般的解法都是用二分法考虑。此题也是刘汝佳那本小白书上的一个例题吧。这里考虑一个index值,如果这个index能满足把这些书分成k份,那么就缩小index的范围,二分的思想就由此产生。首先设置一个上界r,就是总的数页数tot,下界l就设置成0,如果当前index=(l+r)/2能满足正好分成k份,r=index否则l=index。
最后结果返回一个seg值,根据题目要求从后往前贪心选择,模拟就可以了~

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值