uva 10401 Injured Queen Problem

原题:
Chess is a two-player board game believed to have been played in India as early as the sixth century. However, in this problem we will not discuss about chess, rather we will talk about a modified form of the classic n- queens problem. I know you are familiar with plotting n-queens on a chess board with the help of a classic backtracking algorithm. If you write that algorithm
now you will find that there are 92 ways of plotting 8 queens in an 8 × 8 board provided no queens attack each other.In this problem we will talk about injured queens who can move only like a king in horizontal and diagonal direction from current position but can reach any row from current position like a normal chess queen. You will have to find the number of possible arrangements with such injured queens in a particular (n× n) board (with some additional constraints),such that no two queens attack each other.
这里写图片描述
Fig: Injured Queen at a6 can reach the adjacent grey squares. Queen at e4 can reach adjacent grey
squares. The injured queen positions are black and the reachable places are grey.
Input
Input file contains several lines of input. Each line expresses a certain board status. The length of these
status string is the board dimension n (0 < n ≤ 15). The first character of the string denotes the status
of first column, the second character of the string denotes the status of the second column and so on.
So if the first character of the status string is 2, it means that we are looking for arrangements (no two
injured queen attack each other) which has injured queen in column a, row 2. The possible numbers
for rows are 1,2,3,…,D,E,F which indicates row 1, 2, 3… 13, 14, 15. If any column contains ‘?’
it means that in that column the injured queen can be in any row. So a status string ‘1?4??3 means
that you are asked to find out total number of possible arrangements in a (6 × 6) chessboard which
has three of its six injured queens at a1, c4 and f3. Also note that there will be no invalid inputs. For
example ‘1?51’ is an invalid input because a (4 × 4) chessboard does not have a fifth row.
Output
For each line of input produce one line of output. This line should contain an integer which indicates
the total number of possible arrangements of the corresponding input status string.
Sample Input
??????
???????????????
???8?????
43?????
Sample Output
2642
22696209911206174
2098208
0
大意:
给你一个n×n的棋盘,现在让你在棋盘上面放上一个受伤的皇后。每个皇后的攻击范围如图片所示,现在问你一个n×n大小的棋盘有多少种放置方法。给你一个字符串,代表每列的状态,如果字符为’?’表示该列是空的,可以随便放,如果是个数字表示该列已经有一个受伤的皇后。

//状态压缩代码
#include <bits/stdc++.h>

using namespace std;
//fstream in,out;
long long dp[16][32770];
string s;
int GetNum(char c)
{
    if(c>='1'&&c<='9')
        return c-'0';
    else
        return c-'A'+10;
}
bool cmp(int a,int b)
{
    if(a==b)
        return false;
    if(a<<1==b)
        return false;
    if(a>>1==b)
        return false;
    return true;
}
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>s)
    {
        memset(dp,0,sizeof(dp));
        int len=s.size();
        if(s[0]=='?')
            for(int i=0;i<len;i++)
                dp[0][1<<i]=1;
        else
            dp[0][1<<(GetNum(s[0])-1)]=1;
        for(int i=1;i<len;i++)
        {
            if(s[i]=='?')
            {
                for(int j=0,pj=1;j<len;++j,pj=1<<j)
                {
                    if(s[i-1]=='?')
                    {
                        for(int k=0,pk=1;k<len;++k,pk=1<<k)
                            if(cmp(pj,pk))
                                dp[i][pj]+=dp[i-1][pk];
                    }
                    else
                    {
                        int pk=1<<(GetNum(s[i-1])-1);
                        if(cmp(pj,pk))
                            dp[i][pj]+=dp[i-1][pk];
                    }
                }
            }
            else
            {
                int pj=1<<(GetNum(s[i])-1);
                if(s[i-1]=='?')
                {
                    for(int k=0,pk=1;k<len;++k,pk=1<<k)
                        if(cmp(pj,pk))
                            dp[i][pj]+=dp[i-1][pk];
                }
                else
                {
                    int pk=1<<(GetNum(s[i-1])-1);
                    if(cmp(pj,pk))
                        dp[i][pj]+=dp[i-1][pk];
                }
            }
        }
        long long ans=0;
        for(int i=0,pi=1;i<len;++i,pi=1<<i)
            ans+=dp[len-1][pi];
        cout<<ans<<endl;
    }
    return 0;
}
//正常代码
#include <bits/stdc++.h>

using namespace std;
//fstream in,out;
long long dp[16][16];
string s;
int GetNum(char c)
{
    if(c>='1'&&c<='9')
        return c-'0';
    else
        return c-'A'+10;
}
bool cmp(int a,int b)
{
    if(a==b)
        return false;
    if(a+1==b)
        return false;
    if(a-1==b)
        return false;
    return true;
}
int main()
{
    ios::sync_with_stdio(false);
    int n;
    while(cin>>s)
    {
        memset(dp,0,sizeof(dp));
        int len=s.size();
        if(s[0]=='?')
            for(int i=0;i<len;i++)
                dp[0][i]=1;
        else
            dp[0][GetNum(s[0])-1]=1;
        for(int i=1;i<len;i++)
        {
            if(s[i]=='?')
            {
                for(int j=0;j<len;++j)
                {
                    if(s[i-1]=='?')
                    {
                        for(int k=0;k<len;++k)
                            if(cmp(j,k))
                                dp[i][j]+=dp[i-1][k];
                    }
                    else
                    {
                        int k=GetNum(s[i-1])-1;
                        if(cmp(j,k))
                            dp[i][j]+=dp[i-1][k];
                    }
                }
            }
            else
            {
                int j=GetNum(s[i])-1;
                if(s[i-1]=='?')
                {
                    for(int k=0;k<len;++k)
                        if(cmp(j,k))
                            dp[i][j]+=dp[i-1][k];
                }
                else
                {
                    int k=GetNum(s[i-1])-1;
                    if(cmp(j,k))
                        dp[i][j]+=dp[i-1][k];
                }
            }
        }
        long long ans=0;
        for(int i=0;i<len;++i)
            ans+=dp[len-1][i];
        cout<<ans<<endl;
    }
    return 0;
}

解答:
最近刚看了状态压缩的动态规划,看到这道题就想用状态压缩的方法解决出来。不过因为一个皇后可以攻击一整列,所以一列只能放一个皇后,所以用不上状态压缩来表示的每行。 不过这道题练习一下状态压缩入门还是挺好的。
转移方程也非常简单,dp[i][j]+=dp[i-1][k]表示的是第i列放置第j行有多少种放置方法,其中要判断一下j和k是否冲突,也就是j和k是否能互相攻击到。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园的建设目标是通过数据整合、全面共享,实现校园内教学、科研、管理、服务流程的数字化、信息化、智能化和多媒体化,以提高资源利用率和管理效率,确保校园安全。 智慧校园的建设思路包括构建统一支撑平台、建立完善管理体系、大数据辅助决策和建设校园智慧环境。通过云架构的数据中心与智慧的学习、办公环境,实现日常教学活动、资源建设情况、学业水平情况的全面统计和分析,为决策提供辅助。此外,智慧校园还涵盖了多媒体教学、智慧录播、电子图书馆、VR教室等多种教学模式,以及校园网络、智慧班牌、校园广播等教务管理功能,旨在提升教学品质和管理水平。 智慧校园的详细方案设计进一步细化了教学、教务、安防和运维等多个方面的应用。例如,在智慧教学领域,通过多媒体教学、智慧录播、电子图书馆等技术,实现教学资源的共享和教学模式的创新。在智慧教务方面,校园网络、考场监控、智慧班牌等系统为校园管理提供了便捷和高效。智慧安防系统包括视频监控、一键报警、阳光厨房等,确保校园安全。智慧运维则通过综合管理平台、设备管理、能效管理和资产管理,实现校园设施的智能化管理。 智慧校园的优势和价值体现在个性化互动的智慧教学、协同高效的校园管理、无处不在的校园学习、全面感知的校园环境和轻松便捷的校园生活等方面。通过智慧校园的建设,可以促进教育资源的均衡化,提高教育质量和管理效率,同时保障校园安全和提升师生的学习体验。 总之,智慧校园解决方案通过整合现代信息技术,如云计算、大数据、物联网和人工智能,为教育行业带来了革命性的变革。它不仅提高了教育的质量和效率,还为师生创造了一个更加安全、便捷和富有智慧的学习与生活环境。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值