uva 11584 Partitioning by Palindromes

原题:
We say a sequence of characters is a palindrome if it is the same written forwards and backwards. For example, ‘racecar’ is a palindrome, but ‘fastcar’ is not.A partition of a sequence of characters is a list of one or more disjoint non-empty groups of consecutive characters whose concatenation yields the initial sequence. For example, (‘race’,‘car’) is a partition of ‘racecar’ into
two groups.Given a sequence of characters, we can always create a partition of these characters such that each group in the
partition is a palindrome! Given this observation it is natural to ask: what is the minimum number of groups needed for a given string such that every group is a palindrome?
For example:
• ‘racecar’ is already a palindrome, therefore it can be partitioned into one group.
• ‘fastcar’ does not contain any non-trivial palindromes, so it
must be partitioned as (‘f’, ‘a’,‘s’, ‘t’, ‘c’, ‘a’, ‘r’).
Can you read upside-down?
• ‘aaadbccb’ can be partitioned as (‘aaa’, ‘d’, ‘bccb’).
Input
Input begins with the number n of test cases. Each test case consists of a single line of between 1 and
1000 lowercase letters, with no whitespace within.
Output
For each test case, output a line containing the minimum number of groups required to partition the
input into groups of palindromes.Universidad de Valladolid OJ: 11584 – Partitioning by Palindromes
Sample Input
3
racecar
fastcar
aaadbccb
Sample Output
1
7
3
题目大意:
给你一个字符串,问你这个字符串最少能拆分成多少个回文串的组合。

#include <bits/stdc++.h>
using namespace std;
//fstream in,out;
bool mark[1001][1001];//用来记录i到j这段字符串是否是回文
int dp[1001];
string s;
int main()
{
    ios::sync_with_stdio(false);
    int n;
    cin>>n;
    while(n--)
    {
        cin>>s;
        memset(dp,0,sizeof(dp));
        memset(mark,false,sizeof(mark));
        int len=s.size();
        for(int i=0;i<len;i++)
            mark[i][i]=true;
        for(int i=0;i<len-1;i++)
            if(s[i]==s[i+1])
                mark[i+1][i]=mark[i][i+1]=true;//相邻的两个字符相同要先判断
        for(int k=3;k<=len;k++)
        {
            for(int i=0;i<len-k+1;i++)
            {
                int j=k+i-1;
                if(s[i]==s[j]&&mark[i+1][j-1])
                    mark[j][i]=mark[i][j]=true;
            }
        }
        dp[0]=1;
        for(int i=1;i<len;i++)
        {
            if(mark[i][0])
            {
                dp[i]=1;
                continue;
            }
            else
                dp[i]=INT_MAX;
            for(int j=1;j<i;j++)
            {
                if(mark[i][j])
                    dp[i]=min(dp[j-1]+1,dp[i]);
            }
            dp[i]=min(dp[i],dp[i-1]+1);
        }
        cout<<dp[len-1]<<endl;
    }
    return 0;
}

解答:
之前在leetcode上面做过一个最长回文串的题目,没想到在这用上了。用mark[i][j]表示i到j是否是回文串,如果s[i]==s[j]而且mark[i+1][j-1]为真,那么mark[i][]j]肯定为真,也就是i到j是一个回文串。
接下来设置dp[i]表示以字母s[i]为结尾的字符串最少能分解成多少个回文串,那么dp[i]=min(dp[j-1]+1,dp[i]) 当mark[i][j]为真的情况下。
转移方程的意思是如果mark[i][j]为真,那么就把字符串j前面字符能组成最少回文串数加上回文串i到j即可。

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
未来社区的建设背景和需求分析指出,随着智能经济、大数据、人工智能、物联网、区块链、云计算等技术的发展,社区服务正朝着数字化、智能化转型。社区服务渠道由分散向统一融合转变,服务内容由通用庞杂向个性化、服务导向转变。未来社区将构建数字化生态,实现数据在线、组织在线、服务在线、产品智能和决策智能,赋能企业创新,同时注重人才培养和科研平台建设。 规划设计方面,未来社区将基于居民需求,打造以服务为中心的社区管理模式。通过统一的服务平台和应用,实现服务内容的整合和优化,提供灵活多样的服务方式,如推送式、订阅式、热点式等。社区将构建数据与应用的良性循环,提高服务效率,同时注重生态优美、绿色低碳、社会和谐,以实现幸福民生和产业发展。 建设运营上,未来社区强调科学规划、以人为本,创新引领、重点突破,统筹推进、整体提升。通过实施院落+社团自治工程,转变政府职能,深化社区自治法制化、信息化,解决社区治理中的重点问题。目标是培养有活力的社会组织,提高社区居民参与度和满意度,实现社区治理服务的制度机制创新。 未来社区的数字化解决方案包括信息发布系统、服务系统和管理系统。信息发布系统涵盖公共服务类和社会化服务类信息,提供政策宣传、家政服务、健康医疗咨询等功能。服务系统功能需求包括办事指南、公共服务、社区工作参与互动等,旨在提高社区服务能力。管理系统功能需求则涉及院落管理、社团管理、社工队伍管理等,以实现社区治理的现代化。 最后,未来社区建设注重整合政府、社会组织、企业等多方资源,以提高社区服务的效率和质量。通过建立社区管理服务综合信息平台,提供社区公共服务、社区社会组织管理服务和社区便民服务,实现管理精简、高效、透明,服务快速、便捷。同时,通过培育和发展社区协会、社团等组织,激发社会化组织活力,为居民提供综合性的咨询和服务,促进社区的和谐发展。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值