uva 11388 GCD LCM

原题:
The GCD of two positive integers is the largest integer that divides both the integers without any
remainder. The LCM of two positive integers is the smallest positive integer that is divisible by both
the integers. A positive integer can be the GCD of many pairs of numbers. Similarly, it can be the
LCM of many pairs of numbers. In this problem, you will be given two positive integers. You have to output a pair of numbers whose GCD is the first number and LCM is the second number.
Input
The first line of input will consist of a positive integer T. T denotes the number of cases. Each of the
next T lines will contain two positive integer, G and L.
Output
For each case of input, there will be one line of output. It will contain two positive integers a and
b, a ≤ b, which has a GCD of G and LCM of L. In case there is more than one pair satisfying the
condition, output the pair for which a is minimized. In case there is no such pair, output ‘-1’.
Constraints
• T ≤ 100
• Both G and L will be less than 2 31 .
Sample Input
2
1 2
3 4
Sample Output
1 2
-1
中文:
给你两个数的最大公约数和最小公倍数,现在问你这两个数是多少,如果有多个,输出a最小的。如果没有输出-1。(看起来就很简单)

#include <bits/stdc++.h>
using namespace std;

int main()
{
    ios::sync_with_stdio(false);
    long long g,l;
    int t;
    cin>>t;
    while(t--)
    {
        cin>>g>>l;
        if(l%g!=0)
            cout<<-1<<endl;
        else
            cout<<g<<" "<<l<<endl;
    }
    return 0;
}

答案:
这题做的我都不好意思了=_=,还是贴上来吧。两个数的最大公约数是g,最小公倍数是l,那么l肯定能整除g,否则就是不存在。如果存在a,b那么当a为g时明显是最小的,又因为a×b=g×l,可以算出b。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值