uva 10943 How do you add?

原题:
Larry is very bad at math — he usually uses a calculator, which
worked well throughout college. Unforunately, he is now struck in
a deserted island with his good buddy Ryan after a snowboarding
accident.
They’re now trying to spend some time figuring out some good
problems, and Ryan will eat Larry if he cannot answer, so his fate
is up to you!
It’s a very simple problem — given a number N , how many ways
can K numbers less than N add up to N ?
For example, for N = 20 and K = 2, there are 21 ways:
0+20
1+19
2+18
3+17
4+16
5+15

18+2
19+1
20+0
Input
Each line will contain a pair of numbers N and K. N and K will both be an integer from 1 to 100,
inclusive. The input will terminate on 2 0’s.
Output
Since Larry is only interested in the last few digits of the answer, for each pair of numbers N and K,
print a single number mod 1,000,000 on a single line.
Sample Input
20 2
20 2
0 0
Sample Output
21
21
中文:
给你两个数,n和k,问你用k个数组成n有多少种方法,其中组成的数有顺序。例如,n=20,k=2时
0+20
1+19
2+18
3+17
4+16
5+15

18+2
19+1
20+0
有21种

#include <bits/stdc++.h>
using namespace std;
int dp[101][101];
const int mod=1000000;
int main()
{
    ios::sync_with_stdio(false);
    int n,k;
    memset(dp,0,sizeof(dp));
    for(int i=1;i<=100;i++)
        dp[0][i]=dp[i][1]=1;
    for(int i=1;i<=100;i++)
        for(int j=1;j<=100;j++)
            dp[i][j]=(dp[i-1][j]%mod+dp[i][j-1]%mod)%mod;
    while(cin>>n>>k,n+k)
        cout<<dp[n][k]<<endl;
    return 0;
}

解答:
简单的组合数或者是动态规划,就是一道地推的题目。
设置状态dp[n][k]表示有用k个数组成n有多少种方法,那么公式为
dp[n][k]=dp[n-1][k]+dp[n][k-1]
例如,n=5,k=2可以由n=4,k=2加上n=5,k=1的和得到,
n=4,k=2时为
0 4
1 3
2 2
3 1
4 0
那么在右面一列的数上面加上1就得到了5
但是还缺少一个
5 0
加上即可,相当于在dp[5][1]再添一个0

也可以用盒子里面放球的思想来考虑。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值