uva 11461 Square Numbers

原题:
A square number is an integer number whose square root is also an integer. For example 1, 4, 81 are some square numbers. Given two numbers a and b you will have to find out how many square numbers are there between a and b (inclusive).
Input
The input file contains at most 201 lines of inputs. Each line contains two integers a and b (0 < a ≤
b ≤ 100000). Input is terminated by a line containing two zeroes. This line should not be processed.
Output
For each line of input produce one line of output. This line contains an integer which denotes how
many square numbers are there between a and b (inclusive).
Sample Input
1 4
1 10
0 0
Sample Output
2
3
中文:
给你两个数,a,b问你在a和b之间有多少个完全平方数=_=

#include <bits/stdc++.h>
using namespace std;
//fstream in,out;
int table[100001];

bool judge(int x)
{
    int fac=sqrt(x);
    if(fac*fac==x)
        return true;
    return false;
}
int main()
{
    ios::sync_with_stdio(false);
    table[1]=1;
    for(int i=2;i<=100000;i++)
    {
        if(!judge(i))
            table[i]=table[i-1];
        else
            table[i]=table[i-1]+1;
    }
    int a,b;
    while(cin>>a>>b,a+b)
    {
        cout<<table[b]-table[a-1]<<endl;
    }
    return 0;
}

解答:
超级简单题,判定打表即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值