uva 11988 Broken keyboard

原题:
You’re typing a long text with a broken keyboard. Well it’s not so badly broken. The only problem with the keyboard is that sometimes the “home” key or the “end” key gets automatically pressed (internally).You’re not aware of this issue, since you’re focusing on the text and did not even turn on the monitor! After you finished typing, you can see a text on the screen (if you turn on the monitor). In Chinese, we can call it Beiju. Your task is to find the Beiju text.
Input
There are several test cases. Each test case is a single line containing at least one and at most 100,000 letters, underscores and two special characters ‘[’ and ‘]’. ‘[’ means the “Home” key is pressed internally, and ‘]’ means the “End” key is pressed internally. The input is terminated by end-of-file (EOF).
Output
For each case, print the Beiju text on the screen.
Sample Input
This_is_a_[Beiju]_text
[[]][][]Happy_Birthday_to_Tsinghua_University
Sample Output
BeijuThis_is_a__text
Happy_Birthday_to_Tsinghua_University
中文:
给你一段文本,其中’[‘home键,也就跑到文本的头部,’]’代表end键,也就是跑到文本的尾部。
现在给你一段文本,问你把’[‘和’]’按照规定设置后,文本是什么样。

#include <bits/stdc++.h>
using namespace std;
list<string> ls;
string s;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>s)
    {
        ls.clear();
        int i=0;
        string tmp;
        while(i!=s.size())
        {
            int flag=0;
            if(s[i]!='[')
            {
                if(s[i]!=']')
                    tmp+=s[i];
                i++;
            }
            else
            {
                ls.push_back(tmp);
                tmp.clear();
                i++;
                for(;s[i]!=']'&&i!=s.size();i++)
                {
                    if(s[i]=='[')
                        break;
                    tmp+=s[i];
                }
                ls.push_front(tmp);
                tmp.clear();
            }
        }
        ls.push_back(tmp);
        for(auto it=ls.begin();it!=ls.end();it++)
            cout<<*it;
        cout<<endl;
    }
    return 0;
}

解答:
紫书上数据结构的例题,经常在头尾插入值可以用链表。书上代码是用哈希表模拟的链表,我直接使用stl中的list实现。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值