uva 673 Parentheses Balance

原题:
You are given a string consisting of parentheses () and []. A string of this type is said to be correct:
(a) if it is the empty string
(b) if A and B are correct, AB is correct,
(c) if A is correct, (A) and [A] is correct.
Write a program that takes a sequence of strings of this type and check their correctness. Your
program can assume that the maximum string length is 128.
Input
The file contains a positive integer n and a sequence of n strings of parentheses ‘()’ and ‘[]’, one string
a line.
Output
A sequence of ‘Yes’ or ‘No’ on the output file.
Sample Input
3
([])
(([()])))
([()])()
Sample Output
Yes
No
Yes
中文:
就是括号匹配问题。注意数据要一行一行读!

#include <bits/stdc++.h>
using namespace std;

int main()
{
//  ios::sync_with_stdio(false);
    int t;
    stack<char> sc;
    scanf("%d",&t);getchar();
    char s[1000];
    while(t--)
    {
        gets(s);
        int len=strlen(s);
        if(len==0)
        {
            printf("Yes\n");
            continue;
        }
        if(len%2)
        {
            printf("No\n");
            continue;
        }
        while(!sc.empty())
            sc.pop();
        int i=0;
        while(i!=len)
        {
            if(sc.empty())
                sc.push(s[i]);
            else
            {
                if((sc.top()=='('&&s[i]==')')||(sc.top()=='['&&s[i]==']'))
                    sc.pop();
                else
                    sc.push(s[i]);
            }
            i++;
        }
        if(sc.empty())
            printf("Yes\n");
        else
            printf("No\n");
    }

    return 0;
}

解答:
我被这题wa了5次,空串处理的时候一定要一行一行度,不能是字符串为0那样判断!
剩下的就是栈的模拟就可以了

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值