uva 113 Power of Cryptography

原题:
Power of Cryptography

Background

Current work in cryptography involves (among other things) large prime numbers and computing powers of numbers modulo functions of these primes. Work in this area has resulted in the practical use of results from number theory and other branches of mathematics once considered to be of only theoretical interest.

This problem involves the efficient computation of integer roots of numbers.

The Problem

Given an integer n>=1 and an integer p>=1 you are to write a program that determines pn , the positive nth root of p. In this problem, given such integers n and p, p will always be of the form kn for an integer k (this integer is what your program must find).

The Input

The input consists of a sequence of integer pairs n and p with each integer on a line by itself. For all such pairs 1<=n<=200 , 1<=p<= 10101 and there exists an integer k, 1<=k<= 109 such that kn=p .

The Output

For each integer pair n and p the value pn should be printed, i.e., the number k such that kn=p .

Sample Input

2
16
3
27
7
4357186184021382204544
Sample Output

4
3
1234

中文:
给你n和p问你k是多少?其中 kn=p 。数据范围见英文。

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
const ll maxb=pow(10,9);
const double ep=10e-5;
double n,p,k;
ll bin_search()
{
    ll l=1,r=maxb,mid;
    while(l<=r)
    {
        mid=(l+r)/2;
        k=pow(mid,n);
        if(fabs(k-p)<ep)
            return mid;
        if(k<p)
            l=mid+1;
        else
            r=mid-1;
    }
    return 0;
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>p)
    {
        ll ans=bin_search();
        cout<<ans<<endl;
    }
    return 0;
}

解答:
可以用二分枚举k的值。刚开始看数据好大,上来就用高精度模板。结果各种wa,因为高精度没有进位。后来看了uvatoolkit说直接可以用pow函数-_-!!! 然后看了下double的表示范围,然后用double代替高精度即可。

如果这题用pow(p,1/n)这么做就太没意思了。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值