uva 146 ID Codes

It is 2084 and the y ear of Big Brother has finally arrived, albeit a century late. In order to exercise greater control over its citizens and thereby to counter a chronic breakdown in law and order, the Government decides on a radical measure|all citizens are to have a tiny microcomputer surgically implanted in their left wrists. This computer will contains all sorts of personal information as well as a transmitter which will allow people’s movements to be logged and monitored by a central computer. (A desirable side effect of this process is that it will shorten the dole queue for plastic surgeons.) An essential component of each computer will be a unique identification code, consisting of up to 50 characters drawn from the 26 lower case letters. The set of characters for any given code is chosen somewhat haphazardly . The complicated way in which the code is imprinted in to the chip makes it much easier for the manufacturer to produce codes which are rearrangements of other codes than to produce new codes with a different selection of letters. Thus, once a set of letters has been chosen all possible codes derivable from it are used before changing the set.
For example, suppose it is decided that a code will contain exactly 3 occurrences of ‘a’, 2 of ‘b’ and 1 of ‘c’, then three of the allow able 60 codes under these conditions are:
abaabc
abaacb
ababac
These three codes are listed from top to bottom in alphab etic order. Among all codes generated with this set of characters, these codes appear consecutively in this order. Write a program to assist in the issuing of these identification codes. Your program will accept a sequence of no more than 50 lower case letters (which may contain repeated characters) and prin t the successor code if one exists or the message ‘No Successor’ if the given code is the last in the sequence for that set of characters.
Input and Output
Input will consist of a series of lines each containing a string representing a code. The entire file will be terminated b y a line consisting of a single #.
Output will consist of one line for each code read containing the successor code or the words `No
Successor’ .
Sample input
abaacb
cbbaa
#
Sample output
ababac
No Successor

中文:
给你一个字符串,长度不超过50,让你找按照字典序的下一个排列。如果是最后一个排列,那么输出
No Successor

#include <bits/stdc++.h>
using namespace std;
string s;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>s)
    {
        if(s=="#")
            break;
        int i=-1,h=-1;
        for(int j=1;j<s.size();j++)
        {
            if(s[j]>s[j-1])
                i=j;
        }
        if(i==-1)
        {
            cout<<"No Successor"<<endl;
            continue;
        }
        for(int k=1;k<s.size();k++)
        {
            if(s[k]>s[i-1])
                h=k;
        }
        swap(s[i-1],s[h]);
        reverse(s.begin()+i,s.end());
        cout<<s<<endl;
    }
    return 0;
}

解答:
好久没做题了,最近正在学组合数学。讲到生成排列的方法,正好看到这道题,就顺手做了。
使用字典序法生成排列。
算法: 由 P1P2…Pn 生成的下一个排列的算法如下:
1. 求 i=max{j| Pj-1
2. 求 l=max{k| Pi-1
3. 交换Pi-1 与Pl得到P1P2…Pi-1 (P i….Pn ) , 将红色部分顺序逆转,得到结果.

当然,也可以用c++ stl里面的next_permutation,更加简单粗暴

#include <bits/stdc++.h>
using namespace std;
string s;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>s)
    {
        if(s=="#")
            break;
        if(next_permutation(s.begin(),s.end()))
            cout<<s<<endl;
        else
            cout<<"No Successor"<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
在信号处理领域,DOA(Direction of Arrival)估计是一项关键技术,主要用于确定多个信号源到达接收阵列的方向。本文将详细探讨三种ESPRIT(Estimation of Signal Parameters via Rotational Invariance Techniques)算法在DOA估计中的实现,以及它们在MATLAB环境中的具体应用。 ESPRIT算法是由Paul Kailath等人于1986年提出的,其核心思想是利用阵列数据的旋转不变性来估计信号源的角度。这种算法相比传统的 MUSIC(Multiple Signal Classification)算法具有较低的计算复杂度,且无需进行特征值分解,因此在实际应用中颇具优势。 1. 普通ESPRIT算法 普通ESPRIT算法分为两个主要步骤:构造等效旋转不变系统和估计角度。通过空间平移(如延时)构建两个子阵列,使得它们之间的关系具有旋转不变性。然后,通过对子阵列数据进行最小二乘拟合,可以得到信号源的角频率估计,进一步转换为DOA估计。 2. 常规ESPRIT算法实现 在描述中提到的`common_esprit_method1.m`和`common_esprit_method2.m`是两种不同的普通ESPRIT算法实现。它们可能在实现细节上略有差异,比如选择子阵列的方式、参数估计的策略等。MATLAB代码通常会包含预处理步骤(如数据归一化)、子阵列构造、旋转不变性矩阵的建立、最小二乘估计等部分。通过运行这两个文件,可以比较它们在估计精度和计算效率上的异同。 3. TLS_ESPRIT算法 TLS(Total Least Squares)ESPRIT是对普通ESPRIT的优化,它考虑了数据噪声的影响,提高了估计的稳健性。在TLS_ESPRIT算法中,不假设数据噪声是高斯白噪声,而是采用总最小二乘准则来拟合数据。这使得算法在噪声环境下表现更优。`TLS_esprit.m`文件应该包含了TLS_ESPRIT算法的完整实现,包括TLS估计的步骤和旋转不变性矩阵的改进处理。 在实际应用中,选择合适的ESPRIT变体取决于系统条件,例如噪声水平、信号质量以及计算资源。通过MATLAB实现,研究者和工程师可以方便地比较不同算法的效果,并根据需要进行调整和优化。同时,这些代码也为教学和学习DOA估计提供了一个直观的平台,有助于深入理解ESPRIT算法的工作原理。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值