uva 10344 23 out of 5

原题:
Your task is to write a program that can decide whether you can find an arithmetic expression consisting of five given numbers a i (1 ≤ i ≤ 5) that will yield the value 23.
For this problem we will only consider arithmetic expressions of the following from:
(((a π(1) o 1 a π(2) ) o 2 a π(3) ) o 3 a π(4) ) o 4 a π(5) where π : {1,2,3,4,5} → {1,2,3,4,5} is a bijective function and o i ∈ {+,−,∗}(1 ≤ i ≤ 4)
Input
The Input consists of 5-Tupels of positive Integers, each between 1 and 50.
Input is terminated by a line containing five zero’s. This line should not be processed. Input file will have no more than 25 lines.
Output
For each 5-Tupel print ‘Possible’ (without quotes) if their exists an arithmetic expression (as described above) that yields 23. Otherwise print ‘Impossible’.
Sample Input
1 1 1 1 1
1 2 3 4 5
2 3 5 7 11
0 0 0 0 0
Sample Output
Impossible
Possible
Possible

中文:
给你5个1到50的数,问你这6个数用+,-,*三个运算符能否组成23 ?

#include<bits/stdc++.h>
using namespace std;
typedef long long ll;
fstream in,out;
int a[6];
bool vis[6];
bool dfs(int num,int x)
{
    if(x==5)
    {
        if(23==num)
            return true;
        return false;
    }
    for(int i=1;i<=5;i++)
    {
        if(!vis[i])
        {
            vis[i]=1;
            if(dfs(num+a[i],x+1))
                return true;
            if(dfs(num-a[i],x+1))
                return true;
            if(dfs(num*a[i],x+1))
                return true;
            vis[i]=0;
        }
    }
    return false;
}
int main()
{
    ios::sync_with_stdio(false);
//    in.open("in.txt");
//    out.open("out.txt");
    while(cin>>a[1]>>a[2]>>a[3]>>a[4]>>a[5])
    {
        int ter=accumulate(a+1,a+6,0);
        int flag=1;
        if(0==ter)
            return 0;
        memset(vis,false,sizeof(vis));
        for(int i=1;i<=5;i++)
        {
            vis[i]=1;
            int ans=dfs(a[i],1);
            if(ans)
            {
                cout<<"Possible"<<endl;
                flag=0;
                break;
            }
            vis[i]=0;
        }
        if(flag)
            cout<<"Impossible"<<endl;
    }
//    in.close();
//    out.close();
    return 0;
}

解答:
直接暴力搜索即可,注意一定搜到结果的时候要看是否搜了5次,也就是是否5个数都用上了。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值