原题:
A language is a set of strings. And the concatenation of two languages is the set of all strings that are formed by concatenating the strings of the second language at the end of the strings of the first language.
For example, if we have two language A and B such that:
A = {cat, dog, mouse}
B = {rat, bat}
The concatenation of A and B would be:
C = {catrat, catbat, dograt, dogbat, mouserat, mousebat}
Given two languages your task is only to count the number of strings in the concatenation of the two languages.
Input
There can be multiple test cases. The first line of the input file contains the number of test cases, T (1 ≤ T ≤ 25). Then T test cases follow. The first line of each test case contains two integers, M and N (M,N < 1500), the number of strings in each of the languages. Then the next M lines contain the strings of the first language. The N following lines give you the strings of the second language. You can assume that the strings are formed by lower case letters (‘a’ to ‘z’) only, that they are less than 10 characters long and that each string is presented in one line without any leading or trailing spaces.
The strings in the input languages may not be sorted and there will be no duplicate string.
Output
For each of the test cases you need to print one line of output. The output for each test case starts with the serial number of the test case, followed by the number of strings in the concatenation of the second language after the first language.
Sample Input
2
3 2
cat
dog
mouse
rat
bat
1 1
abc
cab
Sample Output
Case 1: 6
Case 2: 1
中文:
给你两组字符串A,B,让你把这两组连接起来A中的字符串在前B中的字符串在后面,问你连接后的字符串有多少种情况。
#include<bits/stdc++.h>
using namespace std;
vector<string> A,B,C;
int t;
int main()
{
ios::sync_with_stdio(false);
cin>>t;
int k=1;
while(t--)
{
int m,n;
A.clear();
B.clear();
C.clear();
cin>>m>>n;
cin.ignore();
for(int i=0;i<m;i++)
{
string s;
getline(cin,s);
A.push_back(s);
}
for(int i=0;i<n;i++)
{
string s;
getline(cin,s);
B.push_back(s);
}
for(int i=0;i<m;i++)
for(int j=0;j<n;j++)
C.push_back(A[i]+B[j]);
sort(C.begin(),C.end());
int ans=unique(C.begin(),C.end())-C.begin();
cout<<"Case "<<k++<<": "<<ans<<endl;
}
return 0;
}
解答:
我为做这种水题而感到耻辱。。。