LA 3135 Argus

原题:
A data stream is a real-time, continuous, ordered sequence of items. Some examples include sensor data, Internet traffic, financial tickers, on-line auctions, and transaction logs such as Web usage logs and telephone call records. Likewise, queries over streams run continuously over a period of time and incrementally return new results as new data arrives. For example, a temperature detection system of a factory warehouse may run queries like the following.
Query-1: “Every five minutes, retrieve the maximum temperature over the past five minutes.”
Query-2: “Return the average temperature measured on each floor over the past 10 minutes.”
We have developed a Data Stream Management System called Argus, which processes the queries over the data streams. Users can register queries to the Argus. Argus will keep the queries running over the changing data and return the results to the corresponding user with the desired frequency.
For the Argus, we use the following instruction to register a query:
Register Q num Period Q num (0 < Q n um ≤ 3000) is query ID-number, and Period (0 < Period ≤ 3000) is the interval between two consecutive returns of the result. After Period seconds of register, the result will be returned for the first time, and after that, the result will be returned every Period seconds. Here we have several different queries registered in Argus at once. It is confirmed that all the queries have different Q num. Your task is to tell the first K queries to return the results. If two or more queries are to return the results at the same time, they will return the results one by one in the ascending order of Q num.
Input
The first part of the input are the register instructions to Argus, one instruction per line. You can assume the number of the instructions will not exceed 1000, and all these instructions are executed at the same time. This part is ended with a line of ‘#’.
The second part is your task. This part contains only one line, which is one positive integer K
(≤ 10000).
Output
You should output the Q num of the first K queries to return the results, one number per line.
Sample Input
Register 2004 200
Register 2005 300
#
5
Sample Output
2004
2005
2004
2004
2005

中文:
给你一堆命令,每一条命令分为Register Q_num Period ,表示每隔Period秒就会产生一个Q_num。现在让你输出前k个Q_num是多少。如果多个事件同时发生,先处理Q_num小的。

#include <bits/stdc++.h>
using namespace std;
struct reg
{
    int q,p,mark;
    reg(int qq,int pp)
    {
        q=qq;
        p=pp;
        mark=p;
    }
    bool operator > (const reg &r) const
    {
        if(this->mark!=r.mark)
            return this->mark>r.mark;
        else
            return this->q>r.q;
    }
};

vector<reg> vr;
string s;
int q,p,k;
void solve()
{
    priority_queue<reg,vector<reg>,greater<reg>> pq(vr.begin(),vr.end());
    while(k>0)
    {
        reg ans=pq.top();
        pq.pop();
        //cout<<ans.q<<" "<<ans.p<<" "<<ans.mark<<endl;
        cout<<ans.q<<endl;
        k--;
        ans.mark+=ans.p;
        pq.push(ans);
    }
    while(!pq.empty())
        pq.pop();
    vr.clear();
}
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>s)
    {
        if(s=="#")
        {
            cin>>k;
            solve();
        }
        else
        {
            cin>>q>>p;
            reg r(q,p);
            vr.push_back(r);
        }

    }
    return 0;
}

解:
训练指南上面紧接着那道“一个简单问题”的题目,亚洲区域赛居然有这么简单的题目!
很简单,只要把这些命令按照Period从小到大建立一个堆,堆顶肯定是Period最小的,输出结果然后弹出后,把刚刚输出命令的时间增加一个Period,然后再放回堆中。输出前k个即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值