uva 1592 Database

原题:
Peter studies the theory of relational databases. Table in the relational database consists of values that are arranged in rows and columns.
There are different normal forms that database may adhere to. Normal forms are designed to
minimize the redundancy of data in the database. For example, a database table for a library might have a row for each book and columns for book name, book author, and author’s email.
If the same author wrote several books, then this representation is clearly redundant. To formally define this kind of redundancy Peter has introduced his own normal form. A table is in Peter’s Normal Form (PNF) if and only if there is no pair of rows and a pair of columns such that the values in the corresponding columns are the same for both rows.
这里写图片描述
The above table is clearly not in PNF, since values for 2rd and 3rd columns repeat in 2nd and
3rd rows. However, if we introduce unique author identifier and split this table into two tables — one containing book name and author id, and the other containing book id, author name, and author email, then both resulting tables will be in PNF.
这里写图片描述

Given a table your task is to figure out whether it is in PNF or not.
Input
Input contains several datasets. The first line of each dataset contains two integer numbers n and m (1 ≤ n ≤ 10000,1 ≤ m ≤ 10), the number of rows and columns in the table. The following n lines contain table rows. Each row has m column values separated by commas. Column values consist of ASCII characters from space (ASCII code 32) to tilde (ASCII code 126) with the exception of comma (ASCII code 44). Values are not empty and have no leading and trailing spaces. Each row has at most 80 characters (including separating commas).
Output
For each dataset, if the table is in PNF write to the output file a single word “YES” (without quotes). If the table is not in PNF, then write three lines. On the first line write a single word “NO” (without quotes). On the second line write two integer row numbers r 1 and r 2 (1 ≤ r 1 ,r 2 ≤ n,r 1 ̸= r 2 ), on the third line write two integer column numbers c 1 and c 2 (1 ≤ c 1 ,c 2 ≤ m,c1 ̸= c2), so that values in columns c 1 and c 2 are the same in rows r 1 and r 2 .
Sample Input
3 3
How to compete in ACM ICPC,Peter,peter@neerc.ifmo.ru
How to win ACM ICPC,Michael,michael@neerc.ifmo.ru
Notes from ACM ICPC champion,Michael,michael@neerc.ifmo.ru
2 3
1,Peter,peter@neerc.ifmo.ru
2,Michael,michael@neerc.ifmo.ru
Sample Output
NO
2 3
2 3
YES
中文:
给你一个n行m列的数据库,现在让你找两个不同行r1,r2和两个不同列c1,c2,使得这两行两列相同。
(r1,c1)与(r2,c1)相同,(r1,c2)与(r2,c2)相同。
找到了输出NO并输出r1 r2 c1 c2
否则输出YES

代码

#include<bits/stdc++.h>
using namespace std;
int n,m;


typedef pair<int,int> node;
vector<vector<string>> database;
int mark[10001][11];
vector<string> split(string s)
{
    vector<string> tmp;
    string res;
    for(int i=0;i<s.size();i++)
    {
        if(s[i]==',')
        {
            tmp.push_back(res);
            res.clear();
        }
        else
        {
            res+=s[i];
        }
    }
    tmp.push_back(res);
    return tmp;
}
map<string,int> id;

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m)
    {
        id.clear();
        database.clear();
        string s;
        cin.ignore();
        for(int i=0;i<n;i++)
        {
            getline(cin,s);
            database.push_back(split(s));
        }
        int k=0;
        for(int i=0;i<n;i++)
        {
            for(int j=0;j<database[i].size();j++)
            {
                if(id.find(database[i][j])==id.end())
                {
                    id[database[i][j]]=k;
                    mark[i][j]=k;
                    k++;
                }
                else
                {
                    mark[i][j]=id.find(database[i][j])->second;
                }
            }
        }

        map<node,int> mb;
//        map<long long,int> ml;
        int flag=0;
        for(int i=0;i<m;i++)
        {
            for(int j=i+1;j<m;j++)
            {
                mb.clear();
                for(int k=0;k<n;k++)
                {
                    node tmp(mark[k][i],mark[k][j]);
                    auto it=mb.find(tmp);
                    if(it==mb.end())
                    {
                        mb[tmp]=k;
                    }
                    else
                    {
                        flag=1;
                        cout<<"NO"<<endl;
                        cout<<it->second+1<<" "<<k+1<<endl;
                        cout<<i+1<<" "<<j+1<<endl;
                        break;
                    }
                }
                if(flag)
                    break;
            }
            if(flag)
                break;
        }
        if(!flag)
        {
            cout<<"YES"<<endl;
        }
    }
    return 0;
}

解答:
紫书上面的例题,教你如何使用STL。由列数小于10,所以枚举两列,然后扫描行,把找到的对应列数记录在map当中,如果再相同的两列当中遇到相同的值,则输出结果即可。

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值