uva 1395 Slim Span

原题:
Given an undirected weighted graph G, you should find one of spanning trees specified as follows.
The graph G is an ordered pair (V,E), where V is a set of vertices {v 1 ,v 2 ,…,v n } and E is a
set of undirected edges {e 1 ,e 2 ,…,e m }. Each edge e ∈ E has its weight w(e). A spanning tree T is a tree (a connected sub-graph without cycles) which connects all the n vertices with n−1 edges. The slimness of a spanning tree T is defined as the difference between the largest weight and the smallest weight among the n − 1 edges of T. For example, a graph G in Figure 5(a) has four vertices {v 1 ,v 2 ,v 3 ,v 4 } and five undirected edges {e 1 ,e 2 ,e 3 ,e 4 ,e 5 }. The weights of the edges are w(e 1 ) = 3, w(e 2 ) = 5, w(e 3 ) = 6, w(e 4 ) = 6, w(e 5 ) = 7 as shown in Figure 5(b).

这里写图片描述

There are several spanning trees for G. Four of them are depicted in Figure 6(a)(d). The spanning
tree T a in Figure 6(a) has three edges whose weights are 3, 6 and 7. The largest weight is 7 and the
smallest weight is 3 so that the slimness of the tree T a is 4. The slimnesses of spanning trees T b , T c
and T d shown in Figure 6(b), (c) and (d) are 3, 2 and 1, respectively. You can easily see the slimness
of any other spanning tree is greater than or equal to 1, thus the spanning tree T d in Figure 6(d) is one
of the slimmest spanning trees whose slimness is 1.
Your job is to write a program that computes the smallest slimness.

这里写图片描述

Input
The input consists of multiple datasets, followed by a line containing two zeros separated by a space.
Each dataset has the following format.
n m
a 1 b 1 w 1
.
.
.
a m b m w m
Every input item in a dataset is a non-negative integer. Items in a line are separated by a space.
n is the number of the vertices and m the number of the edges. You can assume 2 ≤ n ≤ 100 and
0 ≤ m ≤ n(n − 1)/2. a k and b k (k = 1,…,m) are positive integers less than or equal to n, which
represent the two vertices v a k and v b k connected by the k-th edge e k . w k is a positive integer less than
or equal to 10000, which indicates the weight of e k . You can assume that the graph G = (V,E) is
simple, that is, there are no self-loops (that connect the same vertex) nor parallel edges (that are two
or more edges whose both ends are the same two vertices).
Output
For each dataset, if the graph has spanning trees, the smallest slimness among them should be printed.
Otherwise, ‘-1’ should be printed. An output should not contain extra characters.
Sample Input
4 5
1 2 3
1 3 5
1 4 6
2 4 6
3 4 7
4 6
1 2 10
1 3 100
1 4 90
2 3 20
2 4 80
3 4 40
2 1
1 2 1
3 0
3 1
1 2 1
3 3
1 2 2
2 3 5
1 3 6
5 10
1 2 110
1 3 120
1 4 130
1 5 120
2 3 110
2 4 120
2 5 130
3 4 120
3 5 110
4 5 120
5 10
1 2 9384
1 3 887
1 4 2778
1 5 6916
2 3 7794
2 4 8336
2 5 5387
3 4 493
3 5 6650
4 5 1422
5 8
1 2 1
2 3 100
3 4 100
4 5 100
1 5 50
2 5 50
3 5 50
4 1 150
0 0
Sample Output
1
20
0
-1
-1
1
0
1686
50

中文:
给你一个无向图,最多100个节点。现在让你找出这个图的最小生成树,且这个最小生成树的最长边减去最小的边的值最小。

#include<bits/stdc++.h>
using namespace std;
struct node
{
    int f,t,w;
};
vector<node> vn;
int father[102];
int n,m;

int Find(int x)
{
    if(father[x]==x)
        return x;
    return father[x]=Find(father[x]);
}

void ini()
{
    for(int i=1;i<=n;i++)
        father[i]=i;
}
int cmp(const node &n1,const node &n2)
{
    return n1.w<n2.w;
}

int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n>>m,m+n)
    {
        vn.clear();
        int f,t,w;
        for(int i=1;i<=m;i++)
        {
            cin>>f>>t>>w;
            vn.push_back({f,t,w});
        }
        sort(vn.begin(),vn.end(),cmp);
        int con;
        int ans=INT_MAX;
        for(int L=0;L<m;L++)
        {
            con=1;
            ini();
            for(int R=L;R<m;R++)
            {
                int x=Find(vn[R].f);
                int y=Find(vn[R].t);
                if(x!=y)
                {
                    father[x]=y;
                    con++;
                    if(con==n)
                    {
                        ans=min(ans,vn[R].w-vn[L].w);
                        break;
                    }
                }
            }
        }
        if(ans==INT_MAX)
            cout<<-1<<endl;
        else
            cout<<ans<<endl;
    }
    return 0;
}


思路:

紫书上的例题。

首先对边进行排序,枚举区间[L,R]。每次枚举L,然后向后找一个最小生成树,找到生成树后则确定位置R。此时用R将上一次计算的L替换,继续寻找生成树。每次更新最小最大边减去最小边的值,找到最小的即可。

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值