uva 10137 The Trip

原题:
A number of students are members of a club that travels annually to exotic locations. Their destinations in the past have included Indianapolis, Phoenix, Nashville, Philadelphia, San Jose, and Atlanta. This spring they are planning a trip to Eindhoven.
The group agrees in advance to share expenses equally, but it is not practical to have them share every expense as it occurs. So individuals in the group pay for particular things, like meals, hotels, taxi rides, plane tickets, etc. After the trip, each student’s expenses are tallied and money is exchanged so that the net cost to each is the same, to within one cent. In the past, this money exchange has been tedious and time consuming. Your job is to compute, from a list of expenses, the minimum amount of
money that must change hands in order to equalize (within a cent) all the students’ costs.
Input
Standard input will contain the information for several trips. The information for each trip consists of a line containing a positive integer, n, the number of students on the trip, followed by n lines of input, each containing the amount, in dollars and cents, spent by a student. There are no more than 1000 students and no student spent more than $10,000.00. A single line containing 0 follows the information for the last trip.
Output
For each trip, output a line stating the total amount of money, in dollars and cents, that must be exchanged to equalize the students’ costs.
Sample Input
3
10.00
20.00
30.00
4
15.00
15.01
3.00
3.01
0
Sample Output

$10.00

$11.99

中文:
有n个学生出去玩,花了点钱,现在要均摊。如果没有办法完美均摊,那么最多可以差0.01元。现在问你,如果之前每个人掏了一部分钱以后,掏的少的要给掏的多的那些人多少钱?最少可以是多少?

#include<bits/stdc++.h>
using namespace std;

double a[1001];
int n;
int main()
{
    ios::sync_with_stdio(false);
    while(cin>>n,n)
    {
        double tmp=0,ans1=0,ans2=0;
        memset(a,0,sizeof(a));
        for(int i=1;i<=n;i++)
        {
            cin>>a[i];
            tmp+=a[i];
        }
        tmp/=n;
        tmp=round(tmp*100.0)/100.0;
        for(int i=1;i<=n;i++)
        {
            if(a[i]>tmp)
                ans1+=(a[i]-tmp);
            else
                ans2+=(tmp-a[i]);
        }
        cout<<fixed<<setprecision(2)<<'$'<<min(ans1,ans2)<<endl;
    }
    return 0;
}


解答:

本来是做别的题,结果交错了题号,把这道题做了。
先计算平均数,保留两位小数。

然后分别计算小于平均数人当中,平均数减去每个人的差额的和,大于平均数的人中,每个人减去平均数的差额的和。比较一下哪个小即可

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值