DP背包 或 搜索 poj 3628 Bookshelf 2

   
   
题目地址链接: http://poj.org/problem?id=3628
Bookshelf 2

Description

Farmer John recently bought another bookshelf for the cow library, but the shelf is getting filled up quite quickly, and now the only available space is at the top.

FJ has N cows (1 ≤ N ≤ 20) each with some height of Hi (1 ≤ Hi ≤ 1,000,000 - these are very tall cows). The bookshelf has a height of B (1 ≤ B ≤ S, where S is the sum of the heights of all cows).

To reach the top of the bookshelf, one or more of the cows can stand on top of each other in a stack, so that their total height is the sum of each of their individual heights. This total height must be no less than the height of the bookshelf in order for the cows to reach the top.

Since a taller stack of cows than necessary can be dangerous, your job is to find the set of cows that produces a stack of the smallest height possible such that the stack can reach the bookshelf. Your program should print the minimal 'excess' height between the optimal stack of cows and the bookshelf.

Input

* Line 1: Two space-separated integers: N and B * Lines 2..N+1: Line i+1 contains a single integer: Hi

Output

* Line 1: A single integer representing the (non-negative) difference between the total height of the optimal set of cows and the height of the shelf.

Sample Input

5 16
3
1
3
5
6

Sample Output

1

Source





注释:一:搜索是以深搜进行,主要是在找出所给硬币组成的可能的和,然后分别筛选出比所给高度(即:b)大且在遍历的和中最小的sum,即 是所求了。
二:而dp方法很多,这里只介绍一个我认为简单理解的,就是将所有硬币组成的最大和求出,然后从小(即 b)到大分别标出可能存在 的和(若从大到小,还需注意标记问题,读者可以尝试,如不明白,可以留言),然后进行一个遍历,找出已标记并且大于b的最小的 数即为所求的和了,然后根据题意,将该和与b作差即为所求了,输出即可。
搜索代码:
#include<stdio.h>
#include<string.h>
#define maxn 20
#define inf 1000000005
int a[maxn],vis[maxn];
int min=inf;
int n,b,sum;
int dfs(int a[],int m)
{
	int i,j,k;
	for(i=m;i<=n;i++)
	{
		if(vis[i]==0)
		{
			sum+=a[i];
			if(sum<b)
			{
				vis[i]=1;
				dfs(a,i+1);
				vis[i]=0;
				sum-=a[i];
			}
			else
			{
				if(sum<min)min=sum;
				sum-=a[i];
			}
		}
	}
	return min;
}
int main()
{
	int i,j;
	int temp;
	scanf("%d%d",&n,&b);
	sum=0;
	memset(vis,0,sizeof(vis));
	for(i=1;i<=n;i++)scanf("%d",&a[i]);
	printf("%d\n",dfs(a,1)-b);
	return 0;
}

DP代码:

#include<stdio.h>
#include<string.h>
#define inf 20000005
int a[25];
int dp[inf];
int main()
{
	int i,j,k,n,b;
	int sum=0;
	scanf("%d%d",&n,&b);
	for(i=1;i<=n;i++)
	{
		scanf("%d",&a[i]);
		sum+=a[i];
	}
	for(i=0;i<=sum;i++)
		dp[i]=0;
	dp[sum]=1;
	for(i=1;i<=n;i++)
		for(j=b+a[i];j<=sum;j++)
			if(dp[j]==1) dp[j-a[i]]=1;
	for(i=b;i<=sum;i++)
		if(dp[i]==1)break;
	printf("%d\n",i-b);
	return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值