KMP & hdu 1711 Number Sequence

KMP是在传统的简单模式匹配基础上进化来的,通过向右尽量滑动远一点,除去冗余的滑动操作提高效率。更加详细的讲解拜访这位大侠:http://kb.cnblogs.com/page/176818/

编码实现:

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char str[100];
int next[100],len;
void getnext(){
    int i=0,j=-1;
    next[0]=-1;
    while(i<len){
        if(j==-1||str[i]==str[j]){
            i++;
            j++;
            next[i]=j;
        }
        else j=next[j];
    }
}
int main()
{
    //freopen("cin.txt","r",stdin);
    while(cin>>str){
        len=strlen(str);
        getnext();
        printf("str&&next: \n");
        for(int i=0;i<len;i++){
            cout<<i<<": "<<str[i]<<" "<<next[i]<<endl;
        }
    }
    return 0;
}

两个输入输出例子:

abaabcac

str&&next:

0: a -1
1: b 0
2: a 0
3: a 1
4: b 1
5: c 2
6: a 0

7: c 1

abcdabd

str&&next:
0: a -1
1: b 0
2: c 0
3: d 0
4: a 0
5: b 1
6: d 2

next[]保存了str的部分匹配值(前缀和后缀最长的共有元素长度),对于abcdabd字符串的部分匹配值是{0,0,0,0,1,2,0},这表示原字符串前缀abcd没有前后缀公有元素,继续往后看abcda,a是公有元素,所以匹配值是1,abcdab的公有元素有两个,所以匹配值是2……

简单的KMP应用:

hdu 1711

Number Sequence

Problem Description
Given two sequences of numbers : a[1], a[2], ...... , a[N], and b[1], b[2], ...... , b[M] (1 <= M <= 10000, 1 <= N <= 1000000). Your task is to find a number K which make a[K] = b[1], a[K + 1] = b[2], ...... , a[K + M - 1] = b[M]. If there are more than one K exist, output the smallest one.
 

Input
The first line of input is a number T which indicate the number of cases. Each case contains three lines. The first line is two numbers N and M (1 <= M <= 10000, 1 <= N <= 1000000). The second line contains N integers which indicate a[1], a[2], ...... , a[N]. The third line contains M integers which indicate b[1], b[2], ...... , b[M]. All integers are in the range of [-1000000, 1000000].
 

Output
For each test case, you should output one line which only contain K described above. If no such K exists, output -1 instead.
 

Sample Input
  
  
2 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 1 3 13 5 1 2 1 2 3 1 2 3 1 3 2 1 2 1 2 3 2 1
 

Sample Output
  
  
6 -1
这算是单纯的简单运用KMP了:

#include <iostream>
#include<cstdio>
#include<cstring>
using namespace std;
const int maxm=1e4+5,maxn=1e6+5;
int n,m;  //m is shorter
int a[maxn],b[maxm],bnext[maxm];
void getbnext(){
    int i=0,j=-1;
    bnext[0]=-1;
    while(i<m){
        if(j==-1||b[i]==b[j]){
            i++;
            j++;
            bnext[i]=j;
        }
        else j=bnext[j];
    }
}
int KMP(){
    int i=0,j=0;
    while(i<n&&j<m){
        if(j==-1||a[i]==b[j]){
            i++;
            j++;
        }
        else j=bnext[j];
    }
    if(j>=m)return i+1-j;
    else return -1;
}
int main()
{
    //freopen("cin.txt","r",stdin);
    int t,i,j;
    cin>>t;
    while(t--){
        scanf("%d%d",&n,&m);
        for(i=0;i<n;i++)scanf("%d",&a[i]);
        for(i=0;i<m;i++)scanf("%d",&b[i]);
        memset(bnext,0,sizeof(bnext));
        getbnext();
        printf("%d\n",KMP());
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值