hdu 1671 Phone List(字典树·粉刷式标记)

题目:http://acm.hdu.edu.cn/showproblem.php?pid=1671

Description

Given a list of phone numbers, determine if it is consistent in the sense that no number is the prefix of another. Let’s say the phone catalogue listed these numbers: 
1. Emergency 911 
2. Alice 97 625 999 
3. Bob 91 12 54 26 
In this case, it’s not possible to call Bob, because the central would direct your call to the emergency line as soon as you had dialled the first three digits of Bob’s phone number. So this list would not be consistent. 
 

Input

The first line of input gives a single integer, 1 <= t <= 40, the number of test cases. Each test case starts with n, the number of phone numbers, on a separate line, 1 <= n <= 10000. Then follows n lines with one unique phone number on each line. A phone number is a sequence of at most ten digits.
 

Output

For each test case, output “YES” if the list is consistent, or “NO” otherwise.
 

Sample Input

    
    
2 3 911 97625999 91125426 5 113 12340 123440 12345 98346
 

Sample Output

    
    
NO YES
寻找以某个词为前缀的单词是否存在。存在输出NO,不存在输出YES。
在字典树的单词路径上做数字标记,经过一次就+1,数字越大表示该字符在相同的位置上使用的次数越多。第一个例子:

当父节点的count是1了,那么孩子节点的count也一定是1,不可能比父亲的count大,所以某些点的count我就没有画出来。还有一个问题,我们要求的是完整的单词的count,不是单个单词的count所以部分思路和hdu 1251 统计难题有所不同。可以把单词最后那个字符的节点存储在一个数组中,这样不断insert之后,某些节点的count渐渐变大。指针数组里的节点的count自然也变大。
#include<cstdio>
#include<iostream>
#include<cstring>
using namespace std;
struct node{
    int count;
    node *next[10];
    node(){
        count=0;
        memset(next,0,sizeof(next));
    }
};
node *root,*b[10005];
int k=0;
void insert(char *s){
     int length=strlen(s),i;
     node *t=root;
     for(i=0;i<length;i++){
         if(t->next[s[i]-'0']==0){
              t->next[s[i]-'0']=new node(); //cool
         }
         t=t->next[s[i]-'0'];
         t->count++;
     }
     b[k++]=t;
}
void del(node *p){
    if(p==NULL)return ;
    for(int i=0;i<10;i++)del(p->next[i]);
    delete p;
}
int main(){
    //freopen("cin.txt","r",stdin);
    int t;
    cin>>t;
    while(t--){
         int n;
         scanf("%d",&n);
         root=new node();
         k=0;
         char s[50];
         while(n--){
             scanf("%s",s);
             insert(s);
         }
         bool flag=0;
         for(int i=0;i<k;i++){
             if(b[i]->count>1){  flag=1;  break; }
         }
         if(flag)puts("NO");
         else puts("YES");
         del(root);  //it is important
    }
    return 0;
}




评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值