如果找到了一组解X=(x1,x2,x3……xn)',那么X+D=(x1+d,x2+d,x3+d……xn)'也是该系统的一组解。把图形理论和差分系统联系起来,不等式转化成边的信息(看作向量:后者是起点,前者是终点)(x1,x2)=3,(x2,x3)=4,(x3,x1)=2。输入建图,令x1作为源点,那么得到的结果是(x1,x1)=0,(x2,x1)=3,(x3,x1)=7。这对应于(x2,x3)=(x3,x1)-(x2,x1)=(x2,x3)
用spfa算法将x1作为源点S寻找各点的最短路径可以得到这样的值(一般也就是使用spfa算法来解决单源最短路径·差分系统问题)。这也说明,用spfa求源点S到各点的最短路径也就是线性规划问题两点的最大距离,也即是(xs,xi)。如果存在负环回路,那么就不能求出可行解。spfa等算法的时间复杂度参考推荐博客:http://blog.csdn.net/xiazdong/article/details/8193680
好,来谈谈poj 3159 Candies吧:
http://acm.hust.edu.cn/vjudge/problem/viewProblem.action?id=17126
Time Limit: 1500MS | Memory Limit: 131072KB | 64bit IO Format: %I64d & %I64u |
Description
During the kindergarten days, flymouse was the monitor of his class. Occasionally the head-teacher brought the kids of flymouse’s class a large bag of candies and had flymouse distribute them. All the kids loved candies very much and often compared the numbers of candies they got with others. A kid A could had the idea that though it might be the case that another kid B was better than him in some aspect and therefore had a reason for deserving more candies than he did, he should never get a certain number of candies fewer than B did no matter how many candies he actually got, otherwise he would feel dissatisfied and go to the head-teacher to complain about flymouse’s biased distribution.
snoopy shared class with flymouse at that time. flymouse always compared the number of his candies with that of snoopy’s. He wanted to make the difference between the numbers as large as possible while keeping every kid satisfied. Now he had just got another bag of candies from the head-teacher, what was the largest difference he could make out of it?
Input
The input contains a single test cases. The test cases starts with a line with two integers N and M not exceeding 30 000 and 150 000 respectively. N is the number of kids in the class and the kids were numbered 1 through N. snoopy and flymouse were always numbered 1 and N. Then follow M lines each holding three integers A, B and c in order, meaning that kid Abelieved that kid B should never get over c candies more than he did.
Output
Output one line with only the largest difference desired. The difference is guaranteed to be finite.
Sample Input
2 2 1 2 5 2 1 4
Sample Output
5
Hint
#include <iostream>
#include <cstdio>
#include <cstring>
using namespace std;
const int maxn=30005;
int dis[maxn],head[maxn];
int n,m,sum;
bool vis[maxn];
struct node{
int v,w,next;
}edge[150010];
void addedge(int a,int b,int c){
edge[sum].v=b;
edge[sum].w=c;
edge[sum].next=head[a];
head[a]=sum++;
}
bool spfa(int s){
int stack[maxn],outque[maxn],top=0;
memset(dis,0x3f,sizeof(dis));
memset(vis,0,sizeof(vis));
memset(outque,0,sizeof(outque));
stack[top++]=s;
vis[s]=1;
dis[s]=0;
while(top){
int tmp=stack[--top];
vis[tmp]=0;
outque[tmp]++;
if(outque[tmp]>n) return 0; //判断负环,当然这里没有必要写它
int k=head[tmp];
while(k>-1){
if(dis[edge[k].v]>edge[k].w+dis[tmp]){
dis[edge[k].v]=edge[k].w+dis[tmp];
if(vis[edge[k].v]==0){
vis[edge[k].v]=1;
stack[top++]=edge[k].v;
}
}
k=edge[k].next;
}
}
return 1;
}
int main()
{
//freopen("cin.txt","r",stdin);
while(cin>>n>>m){
sum=0;
memset(head,-1,sizeof(head));
int a,b,c;
while(m--){
scanf("%d%d%d",&a,&b,&c);
addedge(a,b,c);
}
spfa(1);
printf("%d\n",dis[n]);
}
return 0;
}