poj 1700 Crossing River(贪心·dp)

题目:http://poj.org/problem?id=1700

Crossing River
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 12177 Accepted: 4613

Description

A group of N people wishes to go across a river with only one boat, which can at most carry two persons. Therefore some sort of shuttle arrangement must be arranged in order to row the boat back and forth so that all people may cross. Each person has a different rowing speed; the speed of a couple is determined by the speed of the slower one. Your job is to determine a strategy that minimizes the time for these people to get across.

Input

The first line of the input contains a single integer T (1 <= T <= 20), the number of test cases. Then T cases follow. The first line of each case contains N, and the second line contains N integers giving the time for each people to cross the river. Each case is preceded by a blank line. There won't be more than 1000 people and nobody takes more than 100 seconds to cross.

Output

For each test case, print a line containing the total number of seconds required for all the N people to cross the river.

Sample Input

1
4
1 2 5 10

Sample Output

17
分析:大意是,一艘船一次最多能载两个人,过河的速度由最慢的那个人决定,现在有N个人需要过河,船划过上岸后如果还有没过河的人就需要再把船划回去。
题目的例子我就看了半天,如果能把例子看懂,这题也基本会做大半了。
过河的两种方式:

刚开始我只想到(2)||-_- 不是所有的情况下都是第一种情况占优,当遇到只有3个人时肯定是第一种以最少耗时的人送人划回船的方案合适。于是贪心和动态规划的思路就形成了。
#include <iostream>
#include <cstdio>
#include <algorithm>
using namespace std;
int p[1005],dp[1005];
int main()
{
    //freopen("cin.txt","r",stdin);
    int t,n;
    cin>>t;
    while(t--){
        scanf("%d",&n);
        for(int i=0;i<n;i++) scanf("%d",&p[i]);
        sort(p,p+n);
        dp[0]=p[0];
        dp[1]=p[1];
        for(int i=2;i<n;i++){
            int t1=dp[i-1]+p[i]+p[0],t2=dp[i-2]+2*p[1]+p[0]+p[i];
            dp[i]=min(t1,t2);
        }
        printf("%d\n",dp[n-1]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值