zoj 2091 Mean of Subsequence(奇怪的贪心)

题目:http://acm.zju.edu.cn/onlinejudge/showProblem.do?problemCode=2091

Mean of Subsequence

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given N numbers in a line, we can determine a continuous subsequence by giving its start position and its length.

PMH and Roy played a game the other day. Roy gives the start position first, then PMH gives the length. Roy wants the mean of the subsequence as large as possible, while PMH wants it as small as possible.

You are to calculate the best result Roy can get, assuming PMH is very clever.


Input

There are multiple testcases.

Each testcase begins with a line containing N only.

The following line contains N numbers, separated by spaces.


Output

For each testcase, you are to print the best mean of subsequece Roy can get, precise to 6 digit after decimal point.


Sample Input

10
2 10 4 6 5 10 10 2 3 2


Sample Output

5.777778

分析:说来忏愧,我并不理解为什么是这样:从a[i]开始的数字序列一定是a[i]--a[n]这一最长段的平均值最小,它的证明我没有看懂:用反证法证明:如果所选长度的最后一个数字不是n  而是kmax与n中间的某个数t,那么也就是说ave(kmax...t)<ave(kmax...n)。那么必有 ave(t+1...n)>ave(kmax...n) 说明最后t+1个数的平均数最大,与题设矛盾。
这题可以说是我很不理解的一题。。。
#include <iostream>
#include <cstdio>
using namespace std;
double a[10005],b[10005];
int main()
{
    //freopen("cin.txt","r",stdin);
    int n,i,j;
    double maxm;
    while(cin>>n){
        for(i=1;i<=n;i++) scanf("%lf",&a[i]);
        maxm=b[n]=a[n];
        for(i=n-1;i>=1;i--){
            b[i]=(a[i]+b[i+1]*(n-i))/(n-i+1);
            maxm=max(maxm,b[i]);
        }
        printf("%.6lf\n",maxm);
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值