求二叉树的先序遍历

求二叉树的先序遍历

Time Limit: 1000 ms Memory Limit: 65536 KiB
Problem Description
 已知一棵二叉树的中序遍历和后序遍历,求二叉树的先序遍历
Input
 输入数据有多组,第一行是一个整数t (t<1000),代表有t组测试数据。每组包括两个长度小于50 的字符串,第一个字符串表示二叉树的中序遍历序列,第二个字符串表示二叉树的后序遍历序列。 
Output
 输出二叉树的先序遍历序列
Sample Input
2
dbgeafc
dgebfca
lnixu
linux
Sample Output
abdegcf
xnliu


#include <stdio.h>
#include <stdlib.h>
#include <string.h>

struct node
{
    char num;
    struct node *l,*r;
};

struct node *kk(char j[],int n,char i[])
{
    if(n<=0)
        return NULL;
    struct node *root;
    root=(struct node *)malloc(sizeof(struct node));
    root->num=j[n-1];
    int v;
    for(v=0;v<n;v++)
    if(i[v]==j[n-1])break;
    root->l=kk(j,v,i);
    root->r=kk(j+v,n-v-1,i+v+1);
    return root;
};

void zz(struct node *head)
{
    if(head==NULL)
        return ;
         printf("%c",head->num);
    zz(head->l);
    zz(head->r);
}
int main()
{
    int a,b;
    char i[1000],j[1000];
    struct node *head;
    scanf("%d",&b);
    while(b--)
    {
    scanf("%s %s",i,j);
    a=strlen(i);
    head=kk(j,a,i);
    zz(head);
    printf("\n");
    }
    return 0;
}

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值