Hdu 2069

Problem Description
Suppose there are 5 types of coins: 50-cent, 25-cent, 10-cent, 5-cent, and 1-cent. We want to make changes with these coins for a given amount of money.

For example, if we have 11 cents, then we can make changes with one 10-cent coin and one 1-cent coin, or two 5-cent coins and one 1-cent coin, or one 5-cent coin and six 1-cent coins, or eleven 1-cent coins. So there are four ways of making changes for 11 cents with the above coins. Note that we count that there is one way of making change for zero cent.

Write a program to find the total number of different ways of making changes for any amount of money in cents. Your program should be able to handle up to 100 coins.
 

Input
The input file contains any number of lines, each one consisting of a number ( ≤250 ) for the amount of money in cents.
 

Output
For each input line, output a line containing the number of different ways of making changes with the above 5 types of coins.
 

Sample Input
  
  
11 26
 

Sample Output
  
  
4 13


法一:枚举;

#include<stdio.h>
#include<stdlib.h>
int main()
{
    int num, sum, i, j, k, l;
    while(scanf("%d", &num)!=EOF)
    {
        if(num==0)
             sum=1;
        else
        {
            sum=0;
            for(i=num/50; i>=0; i--)
                for(j=(num-50*i)/25; j>=0; j--)
                    for(k=(num-i*50-j*25)/10; k>=0; k--)
                        for(l=(num-i*50-j*25-k*10)/5; l>=0; l--)
                             if(i+j+k+l+(num-i*50-j*25-k*10-l*5)<=100)
                                  sum++;
        }
        printf("%d\n", sum);
    }
    return 0;
}

法二:背包

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

int n,dp[110][300];     // dp[j][k] 统计到第i个coins k钱 dived to j 部分 的分法数
int money[5]={1,5,10,25,50};

int main(){

    //freopen("input.txt","r",stdin);

    while(~scanf("%d",&n)){
        memset(dp,0,sizeof(dp));
        dp[0][0]=1;
        for(int i=0;i<5;i++)
            for(int j=1;j<=100;j++)
                for(int k=n;k>=money[i];k--)    //这样写应该使对的,可写成这样for(int k=money[i];k<=n;k++) 也没WA,估计数据弱了
                    dp[j][k]+=dp[j-1][k-money[i]];
        int ans=0;
        for(int i=0;i<=100;i++) //从0开始,注意 dp[0][0]
            ans+=dp[i][n];
        printf("%d\n",ans);
    }
    return 0;
}

法三:母函数:

#include<iostream>
#include<cstdio>
#include<cstring>

using namespace std;

const int N=300;

int c1[N][110],c2[N][110];
int res[N],money[6]={0,1,5,10,25,50};

void Init(){
    memset(c1,0,sizeof(c1));
    memset(c2,0,sizeof(c2));
    c1[0][0]=1;
    for(int i=1;i<=5;i++){
        for(int j=0;j<=250;j++)
            for(int k=0;j+k*money[i]<=250;k++)
                for(int p=0;k+p<=100;p++)       //限制硬币总数不超过100
                    c2[j+k*money[i]][p+k]+=c1[j][p];
        for(int j=0;j<=250;j++)
            for(int p=0;p<=100;p++){    //限制硬币总数不超过100
                c1[j][p]=c2[j][p];
                c2[j][p]=0;
            }
    }
    for(int i=1;i<=250;i++)
        for(int j=0;j<=100;j++)
            res[i]+=c1[i][j];
    res[0]=1;       //别忘了这个
}

int main(){

    //freopen("input.txt","r",stdin);

    int n;
    Init();
    while(~scanf("%d",&n)){
        printf("%d\n",res[n]);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值