UVa OJ 11400 - Lighting System Design

UVa OJ 11400 - Lighting System Design

Problem

You are given the task to design a lighting system for a huge conference hall. After doing a lot of calculation and sketching, you have figured out the requirements for an energy-efficient design that can properly illuminate the entire hall. According to your design, you need lamps of n different power ratings. For some strange current regulation method, all the lamps need to be fed with the same amount of current. So, each category of lamp has a corresponding voltage rating. Now, you know the number of lamps and cost of every single unit of lamp for each category. But the problem is, you are to buy equivalent voltage sources for all the lamp categories. You can buy a single voltage source for each category (Each source is capable of supplying to infinite number of lamps of its voltage rating.) and complete the design. But the accounts section of your company soon figures out that they might be able to reduce the total system cost by eliminating some of the voltage sources and replacing the lamps of that category with higher rating lamps. Certainly you can never replace a lamp by a lower rating lamp as some portion of the hall might not be illuminated then. You are more concerned about money-saving than energy-saving. Find the minimum possible cost to design the system.

Input

Each case in the input begins with n (1 ≤ n ≤ 1000), denoting the number of categories. Each of the following n lines describes a category. A category is described by 4 integers - V (1 ≤ V ≤ 132000), the voltage rating, K (1 ≤ K ≤ 1000), the cost of a voltage source of this rating, C (1 ≤ C ≤ 10), the cost of a lamp of this rating and L (1 ≤ L ≤ 100), the number of lamps required in this category. The input terminates with a test case where n = 0. This case should not be processed.

Output

For each test case, print the minimum possible cost to design the system.

Sample Input

3
100 500 10 20
120 600 8 16
220 400 7 18
0

Sample Output

778

Solution

这道题目一开始其实并没有看懂,不知道他到底要多少瓦灯泡去点亮大厅。后来发现灯泡数量其实是不变的,只要去更换不同的灯泡就行了。

这里没用结构体或者类,而是直接用o[]来记录每种灯泡的排序,d[i]表示到i种灯泡为止,总共要花多少钱

#include <iostream>
#include <cstdio>
#include <cstring>
#include <functional>
#include <algorithm>
using namespace std;

const int maxn = 1001;
int n;
int v[maxn], k[maxn], l[maxn], a[maxn];
int d[maxn], o[maxn], s[maxn];
int main() {
    ios_base::sync_with_stdio(false);
    cin.tie(NULL);
    //freopen("input.txt" , "r", stdin );
    //freopen("output.txt", "w", stdout);
    while (cin >> n && n) {
        for (int i = 1; i <= n; ++i) {
            cin >> v[i] >> k[i] >> l[i] >> a[i];
            o[i] = i;
        }
        sort(o+1, o+n+1, [](int a, int b){return v[a]<v[b];});
        memset(d, 0x3f, sizeof(d));
        d[0] = 0;
        for (int i = 1; i <= n; ++i) {
            s[i] = s[i-1] + a[o[i]];
            for (int j = 0; j <= i; ++j) {
                d[i] = min(d[i], d[j]+(s[i]-s[j])*l[o[i]]+k[o[i]]);
            }
        }
        cout << d[n] << '\n';
    } 
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值