VS出现目标包.NETFramework的目标包没有安装

用VS打开脚本时,弹窗如下图,需要.net framework,否则打开是杂项文件。在这里插入图片描述

Plan A:

选择第二个选项——下载“.NETFramework,Version=v4.7.1”的目标包。项目将不会更改”,浏览器自动打开到下载界面,网址:https://dotnet.microsoft.com/download/visual-studio-sdks?utm_source=getdotnetsdk&utm_medium=referral在这里插入图片描述
选择你需要的目标包下载安装,然后重启VS就可以了。要是现实已经安装过了,不要慌!我们还有Plan B

Plan B:

打开VS安装程序

在这里插入图片描述

然后进入里面选择你要用的VS版本(我这里只有一个版本,所以你们用的哪个版本就选择那个版本的),点击“更多”,然后点击“修改”在这里插入图片描述
等待一下进去之后点击单个组件

在这里插入图片描述

进入之后选择你需要的目标包勾选上,然后点击修改,等待加载完成。重启一下VS就可以了!

在这里插入图片描述
到这里就结束了,如果对你们有帮助就点点赞与关注,对我也是一种鼓励。要是有大佬还有别的办法也一起分享分享。

已标记关键词 清除标记
©️2020 CSDN 皮肤主题: 游动-白 设计师:上身试试 返回首页